Ionic serve not closing NodeJS instances


#1

Hi,

I noticed that when quitting ionic serve (with q), the NodeJS instance doesn’t close. This means that when I run ionic serve again there are now two instances running at the same time. I’m on windows with @ionic/app-scripts 0.0.36 and the latest CLI. After quitting ionic serve, if I close a NodeJS instance from the task manager the terminal displays this error message:

npm ERR! Windows_NT 10.0.14393
npm ERR! argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “run” “watch” "–color"
npm ERR! node v6.2.1
npm ERR! npm v3.9.3
npm ERR! code ELIFECYCLE
npm ERR! myapp@ watch: ionic-app-scripts watch
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the myapp@ watch script ‘ionic-app-scripts watch’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the myapp package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! ionic-app-scripts watch
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs meal-planner
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls myapp
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\cygwin64\home\name\blah\npm-debug.log

On a side note, the app scripts have been improved a ton lately! Great work.

Thanks,
Dharsan


#2

Could you update to the latest CLI version, 2.1.1. This should be fixed in that release.


#3

I did an npm uninstall -g ionic and then I did npm install -g ionic. Still getting the same problem. I’m on:

node 6.2.1
npm 3.9.3
ionic CLI 2.1.1
cordova 6.3.1

I tried both in cygwin and windows command prompt and still get the issue.

Thanks,
Dharsan


#4

I’m getting this error on three separate windows machines with two different ionic projects. All using the versions mentioned above. Should I be trying a different node version or?

-Dharsan


#5

I’m having the same problem as well.
We are a dev team of 5 people.
The projekt is created on one of our 3 mac-using devs.
The 2 windows devs are getting the same error message as mentioned by sudharsan.

Versions are all updated and fine.


#6

Try that command npm install express