Ionic serve –lab not working in vuejs app

ionic serve --lab does not work
http://localhost:8100/ionic-lab it only shows a white screen
i have installed npm i -D -E @ionic/lab but also doesn’t work when i run ionic serve --lab
what do i miss here ?

ionic info


       Require stack:
       - C:\Users\Asus\AppData\Roaming\npm\node_modules\@ionic\cli\lib\project\index.js
       - C:\Users\Asus\AppData\Roaming\npm\node_modules\@ionic\cli\lib\index.js
       - C:\Users\Asus\AppData\Roaming\npm\node_modules\@ionic\cli\index.js
       - C:\Users\Asus\AppData\Roaming\npm\node_modules\@ionic\cli\bin\ionic

Ionic:

   Ionic CLI       : 6.18.1 (C:\Users\Asus\AppData\Roaming\npm\node_modules\@ionic\cli)
   Ionic Framework : @ionic/vue 6.0.1

Capacitor:

   Capacitor CLI      : 3.3.3
   @capacitor/android : 3.4.0
   @capacitor/core    : 3.4.0
   @capacitor/ios     : not installed

Utility:

   cordova-res : 0.15.4
   native-run  : 1.5.0

System:

   NodeJS : v14.16.0 (C:\Program Files\nodejs\node.exe)
   npm    : 8.4.0
   OS     : Windows 10

Hmm, I just tried this with a fresh project and everything seemed to work fine on my end. Not sure if it’s related to windows or now, but I can check with someone on the team who has a windows machine.


m

1 Like

i figured it out. the problem was i had a couple Eslint warnings when i fixed them then

ionic serve --lab

worked correctly.

I’m having a similar problem only using Ionic+Vue. Ionic lab starts but shows Material Design in both windows.
Weirdly enough, the screenshot posted by mhartington showcases the problem (without him even realizing it…? ): the two views are both MD.
Even in the simple tabs template, the two views should appear different.