Ionic serve error "Application not found"


#1

Hi Guys,

I am executing ionic serve command from cli but I am getting an error “Localhost:8100 Application not found”. Refer the attached screen shot.

CLI error with command:

E:\Android\Ionic\ChatBuddy>ionic serve -f chrome
[INFO] Starting app-scripts server: --f chrome --port 8100 --p 8100
       --livereload-port 35729 --r 35729 --address 0.0.0.0 - Ctrl+C to cancel
[11:30:18]  watch started ...
[11:30:18]  build dev started ...
[11:30:18]  clean started ...
[11:30:18]  clean finished in 16 ms
[11:30:18]  copy started ...
[11:30:18]  transpile started ...
[11:30:23]  transpile finished in 4.98 s
[11:30:23]  preprocess started ...
[11:30:23]  deeplinks started ...
[11:30:23]  deeplinks finished in 15 ms
[11:30:23]  preprocess finished in 15 ms
[11:30:23]  webpack started ...
[11:30:23]  copy finished in 5.32 s
[11:30:40]  webpack finished in 17.37 s
[11:30:40]  sass started ...
[11:30:42]  sass finished in 1.87 s
[11:30:42]  postprocess started ...
[11:30:42]  postprocess finished in 10 ms
[11:30:42]  lint started ...
[11:30:42]  build dev finished in 24.32 s
[11:30:42]  watch ready in 24.47 s
[11:30:42]  dev server running: http://localhost:8100/

[INFO] Development server running
       Local: http://localhost:8100

[11:30:46]  lint finished in 4.01 s
[11:35:03]  Failed to open the browser: Command failed: start "" "http://localho
st:8100" Access is denied.

Ionic Error


#2

Try running the cmd as administrator and post the response here.


#3

Try just ionic serve


#4

I am still getting the same error if I open cmd from admin and executing ionic serve


#5

This error is thrown when I type ionic serve


#6

Have you tried turning off firewall for it?


#7

Yes and it is still giving same error


#8

This problem has started when I removed Firefox and installed chrome


#9

This issue is now resolved after installing Firefox and setting it as default. But my concern is why it doesn’t work for chrome?


#10

when i tried to do as you said. i got like this

do you have anymore options?


#11

can you try these steps to create new project

$ ionic start MyTestApp blank

$ cd MyTestApp

$ ionic serve

can you try these three steps and let me know


#12

After making Google Chrome as default browser the problem is resolved.