Ionic Pro, Ionic v1: IOS package


#1

Guy, good evening,
Someone knows what happening with that error, when i try to package ios app in ionic pro?

±---------------------------------±-------------------------------------+
| Lane Context |
±---------------------------------±-------------------------------------+
| DEFAULT_PLATFORM | ios |
| PLATFORM_NAME | ios |
| LANE_NAME | ios package_build |
| DOWNLOAD_CERTS_PROJECT_NAME | NED-APP |
| DOWNLOAD_CERTS_CERT_PATH | /Users/ionic/builds/f44814b7/0/proj |
| | ect-1/cert_file.p12 |
| DOWNLOAD_CERTS_CERT_PASSWORD | Fagoix1977 |
| DOWNLOAD_CERTS_PROVISIONING_PATH | /Users/ionic/builds/f44814b7/0/proj |
| | ect-1/provision_file.mobileprovisio |
| | n |
±---------------------------------±-------------------------------------+
[12:21:19]: Unknown method ‘error!’, supported [:error, :important, :success, :message, :deprecated, :command, :command_output, :verbose, :header, :interactive?, :input, :confirm, :select, :password, :crash!, :user_error!, :shell_error!, :build_failure!, :test_failure!, :abort_with_message!, :not_implemented]

±-----±-----------------------±------------+
| fastlane summary |
±-----±-----------------------±------------+
| Step | Action | Time (in s) |
±-----±-----------------------±------------+
| 1 | default_platform | 0 |
| 2 | create_keychain | 0 |
| 3 | download_certs | 0 |
| 4 | import_certificate | 0 |
| :boom: | update_project_codesi | 0 |
| | gning | |
| 6 | shell command | 0 |
| 7 | delete_keychain | 0 |
±-----±-----------------------±------------+

[12:21:19]: fastlane finished with errors

[!] Unknown method ‘error!’, supported [:error, :important, :success, :message, :deprecated, :command, :command_output, :verbose, :header, :interactive?, :input, :confirm, :select, :password, :crash!, :user_error!, :shell_error!, :build_failure!, :test_failure!, :abort_with_message!, :not_implemented]
Running after script…


#2

Ionic Pro is a hosted and closed source service, so there is not much we, the community, can help you with, sorry. Check these:

You can - and should - contact support at http://ionicframework.com/support#support


#3

But I think I saw the same error in other threads, might want to read through the “Ionic Pro” ones.