Ionic Pro: 'ionic' does not appear to be a git repository

Did you by chance run that command but without the ionic prefix?

git remote add git@git...

I’m trying now, not sure of the outcome, I guess it will end in github error

That result would not shock me. Personally, I don’t use git push Ionic anything anymore. I just refer to the repo itself

git push

@jaydz i tried this git remote add​ etc…

Try pushing to it with a version of what I posted above. Then check on Ionic pro dashboard. Could be a winner.

@jaydz thx i will give it a try, i already have a pro id, so i’ll flush my project before trying… give me 4 minutes please

Yeah, the ionicgit line that starts it should just be git@git

Fingers crossed for you!

it’s just the time if find back my ionic id and app id sorry

Go to Ionic pro dashboard, to specific app, then click settings, and then the git selection on left hand side of page. Your info will be under ‘cloning from Ionic Pro’

That’s the line I now use to push to Ionic, while replacing ‘clone’ with ‘push’

1 Like

Spotted ty @jayds trying =)

@jaydz and it worked brilliant TY jaydz :slight_smile: replacing clone by push did the trick :slight_smile: :grinning:

TY again you’re my hero @jaydz :):grin:

Fantastic! Happy to help. I wouldn’t wish the headache of solving this stuff on my worst enemy. So I’m happy to save you some pain!

Ionic would be wise to make a job offer at this point! :smirk:

If you don’t mind, Mark it as a solution to spare others from suffering as we have!

No worries:) very happy it’s working for you!

I will do just that. Work before pleasure though!


@jaydz thanks again Jaydz, how do i mark a post as solution ? or solved ? I tried but don’t find it.

I think you have to be the original poster. Hopefully people will see our back and forth and use it to their advantage. Officially though, don’t think you can.