Ionic Pro: Ionic Deploy whitescreen



I’m using the deploy pro feature but when I open my app, just after the splashscreen I get a white screen of death.

When building and runningbthe app from xcode, everything is fine if I disable the update feature.
If I let the update complete, I get the white screen.

Here are the logs from the iOS device :

2017-10-12 16:22:23.523299+0200 elvir[28911:9423010] Apache Cordova native platform version 4.3.1 is starting.
2017-10-12 16:22:23.525502+0200 elvir[28911:9423010] Multi-tasking -> Device: YES, App: YES
2017-10-12 16:22:23.741887+0200 elvir[28911:9423010] [MC] Lazy loading NSBundle MobileCoreServices.framework
2017-10-12 16:22:23.743133+0200 elvir[28911:9423010] [MC] Loaded MobileCoreServices.framework
2017-10-12 16:22:23.749383+0200 elvir[28911:9423010] [MC] System group container for path is /private/var/containers/Shared/SystemGroup/
2017-10-12 16:22:23.758821+0200 elvir[28911:9423010] Using UIWebView
2017-10-12 16:22:23.762292+0200 elvir[28911:9423010] [CDVTimer][handleopenurl] 0.087023ms
2017-10-12 16:22:23.764668+0200 elvir[28911:9423010] [CDVTimer][intentandnavigationfilter] 2.316952ms
2017-10-12 16:22:23.764780+0200 elvir[28911:9423010] [CDVTimer][gesturehandler] 0.063002ms
2017-10-12 16:22:23.767408+0200 elvir[28911:9423010] VERSION LABEL: 0.0.1:1504186066:4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:24.183271+0200 elvir[28911:9423010] uuid is: 4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:24.183331+0200 elvir[28911:9423010] ignore version: NOTHING_TO_IGNORE
2017-10-12 16:22:24.183433+0200 elvir[28911:9423010] [CDVTimer][ionicdeploy] 418.624997ms
2017-10-12 16:22:24.183622+0200 elvir[28911:9423010] [CDVTimer][ioniccordovacommon] 0.131965ms
2017-10-12 16:22:24.247076+0200 elvir[28911:9423082] Redirecting to: file:/var/mobile/Containers/Data/Application/B68D3CE7-F59B-451B-8E8F-B0B0869B112A/Library/Application%20Support/4f1edbf0-32ee-4a1c-a325-3d89104704/index.html?cordova_js_bootstrap_resource=/var/containers/Bundle/Application/47C1BA37-91CD-4234-9572-2C2BEA8626D2/
2017-10-12 16:22:24.393084+0200 elvir[28911:9423010] [CDVTimer][splashscreen] 209.414005ms
2017-10-12 16:22:24.409654+0200 elvir[28911:9423010] [CDVTimer][statusbar] 16.438007ms
2017-10-12 16:22:24.411204+0200 elvir[28911:9423010] [CDVTimer][keyboard] 1.371026ms
2017-10-12 16:22:24.411311+0200 elvir[28911:9423010] [CDVTimer][TotalPluginStartup] 649.103999ms
2017-10-12 16:22:24.457224+0200 elvir[28911:9423010] Reloading the web view.
2017-10-12 16:22:24.461279+0200 elvir[28911:9423010] refreshPreferences: HangTracerEnabled: 0
2017-10-12 16:22:24.461339+0200 elvir[28911:9423010] refreshPreferences: HangTracerDuration: 500
2017-10-12 16:22:24.461369+0200 elvir[28911:9423010] refreshPreferences: ActivationLoggingEnabled: 0 ActivationLoggingTaskedOffByDA:0
2017-10-12 16:22:24.487165+0200 elvir[28911:9423010] Resetting plugins due to page load.
2017-10-12 16:22:24.487307+0200 elvir[28911:9423010] uuid is: 4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:24.487329+0200 elvir[28911:9423010] ignore version: NOTHING_TO_IGNORE
2017-10-12 16:22:24.511231+0200 elvir[28911:9423010] Failed to load webpage with error: The operation couldn’t be completed. (NSURLErrorDomain error -999.)
2017-10-12 16:22:24.511797+0200 elvir[28911:9423010] Resetting plugins due to page load.
2017-10-12 16:22:24.511871+0200 elvir[28911:9423010] uuid is: 4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:24.511888+0200 elvir[28911:9423010] ignore version: NOTHING_TO_IGNORE
2017-10-12 16:22:25.316381+0200 elvir[28911:9423010] Finished load of: file:///var/mobile/Containers/Data/Application/B68D3CE7-F59B-451B-8E8F-B0B0869B112A/Library/Application%20Support/4f1edbf0-32ee-4a1c-a325-3d89104704/index.html?cordova_js_bootstrap_resource=/var/containers/Bundle/Application/47C1BA37-91CD-4234-9572-2C2BEA8626D2/
2017-10-12 16:22:25.432643+0200 elvir[28911:9423010] Ionic Native: deviceready event fired after 157 ms
2017-10-12 16:22:26.587504+0200 elvir[28911:9423010] version is: 0.0.1
2017-10-12 16:22:26.587560+0200 elvir[28911:9423010] uuid is: 4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:26.587578+0200 elvir[28911:9423010] channel is: Master
2017-10-12 16:22:26.587587+0200 elvir[28911:9423010] JSON Error: (null)
2017-10-12 16:22:26.587917+0200 elvir[28911:9423010] JSON: {
    data =     {
        available = 1;
        compatible = 1;
        snapshot = "4f1edbf0-32ee-4a1c-a325-3d89104704";
        url = "";
    meta =     {
        "request_id" = "<null>";
        status = 200;
        version = "2.0.0-sdlc-beta.0";
2017-10-12 16:22:26.587958+0200 elvir[28911:9423010] compatible: True
2017-10-12 16:22:26.587968+0200 elvir[28911:9423010] available: True
2017-10-12 16:22:26.587977+0200 elvir[28911:9423010] update uuid: 4f1edbf0-32ee-4a1c-a325-3d89104704
2017-10-12 16:22:26.587985+0200 elvir[28911:9423010] update is false
2017-10-12 16:22:26.588003+0200 elvir[28911:9423010] THREAD WARNING: ['IonicDeploy'] took '1155.294922' ms. Plugin should use a background thread.

Someone with an idea ?


Ionic Pro is a hosted and closed source service, so there is not much we, the community, can help you with, sorry. Check these:

You can - and should - contact support at


Same issue here. App loads fine. Then I quit. Then I reload it —> white screen. (in testflight)


Same for you:


What @Sujan12 said, or it’s a problem with customurlscheme plugin (if you have it) and / or your app not being configured correctly in Apple Developer Portal (associated domains not enabled on the app). The ‘handleopenurl’ comment in your error suggests something related to customurlscheme plugin (or perhaps deep links plugin)

Why does it work the first time? I dunno. Technology is a headache. But a similar problem was solved by enabling associated domains.


I’ve contacted the ionic pro support and it was an issue on their side.
There was an update recently and the problem has been solved!

So if you run into similar issue, juste check your plugins version and update them if necessary!


its happening with me today. May I know which plugin you updated to sort out this issue?


I also have the same problem with ionic pro code updates. Can you explicitely state how to fix that? I created my custom additional channel called Dev and installed plugin for the app build to keep track the Dev channel. Indeed, the commit is built and deployed to Dev. However, after the update is downloaded and unzipped i see white screen. No errors in console. Application just hangs on with white screen


What exactly I have to check? Everything is working when i build the app whith the installed plugins at ios and android