Ionic Pro creates old build version


#1

Hi

I try to create an android debug build using ionic pro.
For the start i unlinked the app and deleted the app on ionic pro and created a new one.

I linked the app and pushed my repo to ionic pro.
Then i go on my commit and start an android -> debug build.
The build is sucessfull, I download the apk file and run it on my emulator and device but it shows me a really old version of my build. It shows a completely old login screen.
But when I download the ionic pro repo to my local pc I can’t even find that old login view?

So I think ionic pro is having some caching problem on their site. Maybe because we have used ionic cloud in the past? Don’t know what else I can try. If I build my app locally it works fine.

Best regards
Timon


#2

How do you do that?

Is your current master pushed to the ionic remote?


#3

I clone it with
git clone git@git.ionicjs.com:USERNAME/PROJECTNAME.git
you find more infos under ionic pro -> settings -> git.

Yes my current master is pushed to the ionic remote. I can just compare the downloaded version from git clone with my current version. But somehow it still builds me an old version.


#4

I tried to solve this issue for 1 month in my project, the only way I was able to solve it was by creating a new project importing only the src page, installing every plugin again. Ionic Team gave me a solution but I can’t tell if it works because it was after I made a new project.

  1. Update ionic-angular
  2. Run ionic doctor check
  3. Delete the app’s node_modules/​ directory
  4. Delete the app’s package-lock.json​ file
  5. Run npm install​ (which will regenerate what you deleted above)
  6. Run npm run build​

#5

hi mateuspetter

thanks for your answer I will try it and let you know if it worked.
Did the problem in the new project occur again for you?


#6

It has never happened again, everytime I run builds I follow these steps and I always use Ionic Pro.


#7

could you share your package.json? I think some combination of versions just don’t work and it would be nice to have a working sample.


#8

It just gives me new errors if I need to update all my package.json … did you use your current package.json for your new project?


#9

I made a completely new project, then I imported only the src folder (didn’t import config.xml or package.json) from my old project and re-installed everything manually.