Ionic pro and cordova-plugin-ionic glitch

I started to migrate project to ionic pro account, i used deploy updates feature, and tried to switch app to new “ionic pro”.

As per instructions, i added plugins:

cordova plugin add cordova-plugin-ionic --save --variable APP_ID="********" --variable CHANNEL_NAME="Master" --variable UPDATE_METHOD="auto"

after install this plugin,

ionic cordova run ios --device --livereload --consolelogs --serverlogs

generate error:


The following build commands failed:
Ld /Users/macbook/Library/Developer/Xcode/DerivedData/PremoveExpert-dbeyuqejjssmsofuoiwshymllzky/Build/Intermediates.noindex/ArchiveIntermediates/PremoveExpert/IntermediateBuildFilesPath/ normal arm64
(1 failure)
Error: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/macbook/IOS/PremoveExpert/platforms/ios/cordova/build-debug.xcconfig,-workspace,PremoveExpert.xcworkspace,-scheme,PremoveExpert,-configuration,Debug,-destination,generic/platform=iOS,-archivePath,PremoveExpert.xcarchive,archive,CONFIGURATION_BUILD_DIR=/Users/macbook/IOS/PremoveExpert/platforms/ios/build/device,SHARED_PRECOMPS_DIR=/Users/macbook/IOS/PremoveExpert/platforms/ios/build/sharedpch

I noticed, this plugin conflicts with already installed ionic-plugin-deploy

if remove it, app starts but stucks by runtime error

Ionic Deploy: Disabled! Deploy plugin is not installed or has not loaded. Have you run `ionic plugin add ionic-plugin-deploy` yet?
warn — vendor.js:1:685833

if install it, appear build bug as above.

additional info:

ld: 258 duplicate symbols for architecture arm64
        clang: error: linker command failed with exit code 1 (use -v to see invocation)

Can you create a new project with ionic start blank blank and add the plugin/functionality there and see if it builds on Pro?

Yes, at empty project, plugin added and it builds and run on device.

App, which not works, plugins list:
com-sarriaroman-photoviewer 1.1.10 "PhotoViewer"
com.googlemaps.ios 2.1.1 "Google Maps SDK for iOS"
cordova-pdf-generator 1.5.4 "PDFGenerator"
cordova-plugin-add-swift-support 1.7.0 "AddSwiftSupport"
cordova-plugin-app-version 0.1.9 "AppVersion"
cordova-plugin-camera 2.4.1 "Camera"
cordova-plugin-compat 1.1.0 "Compat"
cordova-plugin-crop 0.3.1 "CropPlugin"
cordova-plugin-datepicker 0.9.3 "DatePicker"
cordova-plugin-device 1.1.6 "Device"
cordova-plugin-document-viewer 0.9.5 "SitewaertsDocumentViewer"
cordova-plugin-email 1.2.6 "EmailComposer"
cordova-plugin-file 4.3.3 "File"
cordova-plugin-file-opener2 2.0.19 "File Opener2"
cordova-plugin-file-transfer 1.6.3 "File Transfer"
cordova-plugin-geolocation 2.4.3 "Geolocation"
cordova-plugin-googlemaps 1.4.3 "cordova-googlemaps-plugin"
cordova-plugin-image-resizer 1.0.0 "ImageResizer"
cordova-plugin-inappbrowser 1.7.0 "InAppBrowser"
cordova-plugin-ionic 1.1.8 "IonicCordova"
cordova-plugin-network-information 1.3.3 "Network Information"
cordova-plugin-screen-orientation 2.0.1 "Screen Orientation"
cordova-plugin-splashscreen 4.0.3 "Splashscreen"
cordova-plugin-statusbar 2.2.1 "StatusBar"
cordova-plugin-whitelist 1.3.1 "Whitelist"
cordova-plugin-x-toast 2.6.0 "Toast"
cordova-sqlite-storage 2.0.4 "Cordova sqlite storage plugin"
es6-promise-plugin 4.1.0 "Promise"
info.protonet.imageresizer 0.1.1 "Image Resizer"
ionic-plugin-keyboard 2.2.1 “Keyboard”

Well, you probably won’t like that answer, but next step would be to add these all to the newly created app and see if you get the same error. If you do, revert back to before adding them and then repeat these steps until you figure out which one breaks it: add one, build and see if it stillf works.

lol, you read my thoughts, in process

1 Like

situation appeared next, when i added all plugins to empty project, it still worked.
So i decided to move code to it lol.

1 Like

Well, whatever works :wink:

So problem solved?

i can’t answer fully, now apply TS strict mode to exists scripts, i noticed crash app at deploy with cordova-plugin-ionic, so will investigate deepper and will answer