Ionic.Platform.ready not firing on iOS 9, 1.1.0-nightly-1583

Like in topic (iPad 2 mini, 9.0.2), any solutions?

I have used angular.element(document).ready in my code, but inside Ionic bundle problem is still present.

Has this been fixed yet? I seem to still be having the issue with iOS9 (9.1).

I also ran into that bug with iOS 9.2 on an iPad mini. None of the common device ready triggers were be fired…any fixes already available?

Any updates to this? I’ve just picked up an existing project, made sure everything is up to date only to find it doesn’t work as platform.ready isn’t firing.

It works fine in the browser, but never fires in the emulator or device. Device is 9.2.1, emulator is 9.2

Just tried on an iPhone 4s with IOS 8.4.1 and get the same issue, so it’s not the IOS version. I’m going to have to go back to basics to see if I can narrow it down. There are no errors thrown, so not sure what’s going wrong.

Further experiments. Brand new BLANK project:

Cordova CLI: 5.4.1
Ionic: 1.2.4
Ionic CLI: 1.7.13
Ionic App Lib: 0.6.5
ios-deploy: 1.8.4
ios-sim: 5.0.6
Node: 5.4.1

I have added an alert statement inside $ionicPlatform.ready in app.js

Works fine and fires when I do “ionic serve” in the browser

I can’t launch from the command line, but can run the project from Xcode in either emulator or on device. The app launches, but the alert never fires.

The biggest issue I have with Ionic is that unless you are constantly working with it, then the whole heap of dependencies just collapses in on itself and stops working.

Anyone any ideas?

Solved by checking and re-adding plugins, running “ionic build ios” at the command line and THEN launching and running from XCode. Jumping through hoops, but at least it works.

this solved it in my case:

  • remove/adding the device plugin (cordova-plugin-device)
  • remove/add platform ios again
  • build the project
  • open in xcode

I followed schulettla’s steps but the problem persists in iOS 10. Opened the issue 8369.

1 Like