Ionic iOS 11 build error with Xcode 9


#1

I’ve tried every possible solution I could find for this cryptic error and no luck.

In my Ionic project, I’ve added the platform, but when I go to run the project in the simulator through Xcode, I get this error:

error: cannot parse the debug map for "/Users/XXX/Library/Developer/Xcode/DerivedData/ProjectName-aedfralrxnetyceopmcioxkdhsxh/Build/Products/Debug-iphonesimulator/ProjectName.app/ProjectName": No such file or directory

Not sure where else to turn other than here. Any help would be appreciated!


#2
  1. What is your ionic info output?
  2. Why are you using Xcode instead of Ionic CLI?
  3. Can you emulate a new project created with ionic start?

#3

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils : 1.13.0
ionic (Ionic CLI) : 3.13.0

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

@ionic/app-scripts : 3.0.0
Cordova Platforms : none
Ionic Framework : ionic-angular 3.7.1

System:

ios-deploy : 1.9.2
ios-sim : 6.1.2
Node : v6.9.1
npm : 5.5.1
OS : macOS Sierra
Xcode : Xcode 9.0 Build version 9A235

Misc:

backend : legacy


#4

And I’m trying to run the simulator. And yes I can… I just keep getting that error when I’m trying to build in the CLI or if I’m trying to run the simulator.


#5

Please re-read my question 2) and 3).


#6

I answered those questions.


#7

No you didn’t - at least the words you typed don’t.
But you don’t have to, I just can’t help you then.


#8
  1. I’m using Xcode because I added the platform to my project and then opened the project in Xcode, so I could launch the simulator from Xcode. After attempting to do that, the project fails and gives me the error I described.

  2. I cloned into the conference app from Ionic’s starters and was able to successfully run the project.

Does that answer your questions?


#9

Yes :slight_smile:

re 2) have you tried ionic cordova emulate ios?
re 3) This tells us the problem is with your project and not with your environment in general.

Why does this show empty here? What does ionic cordova platform list return?

You might want to remove and re-add the ios platform and see if your problem goes away.


#10

I removed and readded.
Still the same error.
Same error also occurs when running ionic cordova emulate ios

Here is the output of that command:

✔ Running command - done!
Installed platforms:
  ios 4.5.2
Available platforms:
  android ~6.3.0
  blackberry10 ~3.8.0 (deprecated)
  browser ~5.0.0
  osx ~4.0.1
  ubuntu ~4.3.4 (deprecated)
  webos ~3.7.0
  windows ~5.0.0
  www ^3.12.0

#11

So you have this output for platforms list and still Cordova Platforms : none in ionic info?


#12

It’s showing up as this now:

Cordova Platforms  : ios 4.5.2

Still not building however.


#13

@Sujan12

Not sure what else I can do here, as the project is still not building.


#14

No idea. Can you try building it on another machine?


#15

Don’t have one handy, unfortunately.


#16

It’ll build for Android, however, which is another annoying part of this whole thing.


#17

Your error message indicates a problem with the data of a Simulator somehow. I don’t really know what this path is used for. Uninstall and reinstall the simulator? Or whole Xcode?


#18

Maybe your platform need to be clean like in this solution: