Ionic.io.bundle.js:5844 Uncaught TypeError: Cannot read property 'init' of undefined


#1

I have been following the Alpha to Beta migration document to get our push notifications updated before the deprecation timeline. However I ran into this error and cannot seem to get around it.

The error:
ionic.io.bundle.js:5844 Uncaught TypeError: Cannot read property ‘init’ of undefined

It is for the line of code:

self._plugin = self._getPushPlugin().init(self._config.pluginConfig);

Seems to me this would mean that I am having issues with the plugins, but that seems correct to me:

com.ionic.keyboard 1.0.4 "Keyboard"
cordova-plugin-app-event 1.1.0 "Application Events"
cordova-plugin-device 1.1.1 "Device"
cordova-plugin-device-orientation 1.0.2 "Device Orientation"
cordova-plugin-geolocation 2.1.0 "Geolocation"
cordova-plugin-splashscreen 3.1.0 "Splashscreen"
cordova-plugin-whitelist 1.2.1 "Whitelist"
de.appplant.cordova.plugin.local-notification 0.8.4 "LocalNotification"
phonegap-plugin-push 1.6.2 "PushPlugin"
uk.co.workingedge.phonegap.plugin.launchnavigator 2.9.8 "Launch Navigator"

Anyone seen this issue or have any ideas on what I am doing wrong? Thanks.


#2

Same issue Please advise


#3

+1 I’m getting the same error, any news?