Ionic input type=number decimal key resets input

Hello there! I’ve been developing in ionic 4, and this ‘bug’ is driving me crazy.

Ionic CLI 5.2.1
Angular 7.1.4
OS: Windows x64

Basically I put a ion-input type=“number” in HTML file of a page and when user clicks decimal button (’.’) input clears itself.

HTML Content:

    <ion-buttons slot="start">
          <ion-icon slot="icon-only" name="menu"></ion-icon>
    <ion-title>Kasa Ekle</ion-title>

    <ion-label position="floating">Bakiye</ion-label>
    <ion-input type="number" value="0"></ion-input>
  <ion-button expand="full" (click)="AddSafe()">Ekle</ion-button>

Typescript Content:

import { Component, OnInit } from '@angular/core';
import { MbAcExchangeType } from 'src/app/classes/MbAcSafe';
import { Globals } from 'src/app/classes/Globals';
import { QuickToast } from 'src/app/classes/Helper';
import { ToastController } from '@ionic/angular';
import { Location } from '@angular/common';

  selector: 'app-add-safe',
  templateUrl: './',
  styleUrls: ['./'],
export class AddSafePage implements OnInit {
  public name : string;
  public exchange : number;
  public balance : number;
  public get exchanges(): MbAcExchangeType[] {
    return Globals.AppState.exchanges;

  constructor(private toast : ToastController, private location : Location) { }

  ngOnInit() {

    Globals.AppState.AddSafe(,, this.balance)
    .then(() => {
      QuickToast(this.toast, "Kasa eklendi!", 3000);
    .catch((e) => {
      QuickToast(this.toast, "Kasa eklerken hata, programı yeniden başlatmayı deneyin.", 3000);

I’ve also had another 2 inputs, but wanted to check if it works without them I deleted them.
This is the result:

As seen on gif, pressing dot key causes input to clear, but when input is empty it causes dots to appear. I used scrcpy for screencast, so I tried to write with keyboard. Tried to input 12.0 but it still resets, entering 12,0 works tho. I also deleted ngModel in order to test if that was causing anything, but it still does not work. Any help?

Bump? I wasn’t able to find an issue related to this.

We have exactly the same issue. I tried to use “tel” instead but the different symbols for phone numbers are too much for our users.

I wasn’t able to update my Ionic to latest version. Today or tomorrow I will try this in up-to-date version. If still does not work, will post an issue in github.

Same issue here. Did you find a solution?

There is an open issue for this on GitHub (
Apparently the problem started from @ionic/angular 4.6.0.
I tried 4.7.1 and it works fine, without the issue.