Ionic has stopped building application. No Error though [solved]

So I’ve come to do some coding on my project today but when running ‘Ionic Cordova Run Android’ (the command that has previously worked fine onto my physical device) It gives the following output before throwing me back to the command line:

PS C:\Development\TripTrackr> ionic cordova run android
[INFO] Running app-scripts build: --platform android --target cordova

[17:33:36]  build dev started ...
[17:33:36]  clean started ...
[17:33:36]  clean finished in 2 ms
[17:33:36]  copy started ...
[17:33:36]  transpile started ...
[17:33:39]  transpile finished in 2.40 s
[17:33:39]  preprocess started ...
[17:33:39]  deeplinks started ...
[17:33:39]  deeplinks finished in 30 ms
[17:33:39]  preprocess finished in 32 ms
[17:33:39]  webpack started ...
[17:33:39]  copy finished in 2.66 s
PS C:\Development\TripTrackr>

I’ve looked all over and have tried various things, such as uninstalling and reinstalling ionic and cordova. Some suggestions have been to try the command without ionic ‘Cordova run android’, which does run but results in a plain white screen on the device (which might be right as it needs debugging, however adb logcat isn’t showing anything I’d expect error wise)

I’m running on windows 10, with a nexus 5 hooked up over usb. It can definately be seen by adb and has worked recently - I can’t think of any changes made though. I’m developing in VS Code but using the commandline for debugging as I found it works way better (apart from breakpoints)

Finally, I’ll post my ionic info below:

PS C:\Development\TripTrackr> ionic info

cli packages: (C:\Users\jonba\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.9.2
    ionic (Ionic CLI) : 3.9.2

global packages:

    Cordova CLI : 7.0.1

local packages:

    @ionic/app-scripts : 2.1.3
    Cordova Platforms  : android 6.2.3
    Ionic Framework    : ionic-angular 3.6.0


    Android SDK Tools : 26.0.2
    Node              : v6.11.1
    npm               : 5.3.0
    OS                : Windows 10

PS C:\Development\TripTrackr>

Really appreciate someones help with this. I’m already balding - this is only speeding up the process!

EDIT: Forgot to mention! Running ‘ionic serve’ produces identical behaviour.

I have no solution for you. But I can see it on my machine that I have also since a few days problems that building stopps on emultor in the same way. Stopping cli and restart it mostly helps for me, also longer not working in vscode makes the pc completly unusable and it takes sometimes a half of an hour from the first click and it is usable again.

Further it seems one of the last updates of win10 makes huge problems with tranferring files from win10 over usb to android devices. Files can go completly lost without the possibiliy to recover it. I have no article in english where this is discribed and which workarounds are possible, but maybe you should search for it and test it, if you an our device is affected.

So maybe one of the new “features” MS is proud to deliver.

Best regards anna-liebt.

Thanks for the reply Anna-Liebt. I’ve been working on this more this evening by comparing a backup which I restored, that did compile and run correctly (ruling out what I thought might be an incompatability issue I may have had with a Windows patch as you suggested).

Turns out on my part, while I’m still not sure of the cause, I believe it had something to do with me incorrectly creating a popover component. I placed it into the same ts file as it’s parent however it only started working when splitting it out from that file. I’m guessing there is something I’ve missed as I’ve seen examples of the popover class beingin the same ts file as it’s parent but it’s working this way anyway.

Incidentally, The reason I started using a physical phone was because the emulator was constantly causing me problems with this setup! I’ve not had any particular problems using the phone over usb though I’m afraid.

1 Like

I have definitely seen this cause problems, and recommend always having one file per component.