Ionic Gradle Update


#1

I want run my app in Android so i ran this command ionic cordova run android -l --debug
but there is error saying this

Minimum supported Gradle version is 4.4. Current version is 4.1. If using the gradle wrapper

I update the distributionUrl but it restored the same version after i ran above command. i also tried Change BuildersGradle.js but error occurs. im so frustrated about this .any help

this is my ionic info

cli packages: (C:\Users\Chamara\AppData\Roaming\npm\node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 8.0.0

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : android 7.0.0 browser 5.0.3
Ionic Framework    : ionic-angular 3.9.2

System:

Node : v8.11.1
npm  : 5.6.0
OS   : Windows 10

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

#2

Install a newer version of Gradle https://gradle.org/install/