"ionic emulate ios" command not starting emulator

When I run the below commands, instead of starting the emulator and displaying the app I get NO feedback from the prompt:

SMV:firstIonicApp$ ionic platform add ios
Updated the hooks directory to have execute permissions
Platform ios already added.
SMV:firstIonicApp $ ionic build ios
SMV:firstIonicApp $ ionic emulate ios
SMV:firstIonicApp $

I am running node v4.1.0 along with the following installed globally:

├── bower@1.5.2
├── cordova@5.3.1
├── firebase-tools@1.2.0
├── flightplan@0.6.4
├── gulp@3.9.0
├── ionic@1.6.4
├── ios-sim@5.0.1
├── node-inspector@0.10.2
├── npm@2.14.1
└── pm2@0.14.3

Your system information:

Cordova CLI: 5.3.1
Gulp version: CLI version 3.9.0
Gulp local:
Ionic Version: 1.1.0
Ionic CLI Version: 1.6.4
Ionic App Lib Version: 0.3.8
ios-deploy version: 1.7.0
ios-sim version: 5.0.1
OS: Mac OS X Yosemite
Node Version: v4.1.0
Xcode version: Xcode 7.0 Build version 7A220

Unfortunately I am experiencing the exact same problem.

ionic emulate ios does not start the emulator and does not print any error.

My system information:

Cordova CLI: 5.3.3
Ionic CLI Version: 1.7.8
Ionic App Lib Version: 0.6.4
ios-deploy version: 1.8.2
ios-sim version: 5.0.3
OS: Mac OS X El Capitan
Node Version: v5.0.0
Xcode version: Xcode 7.1 Build version 7B91b

I’ve tried reinstalling cordova as described here:

I also tried to reinstall node + npm and even setting up a new User on OSX.

I’ve tried running iOS 8.4 and set targets explicitly.

I created a pure cordova app and had the same behavior there as well (cordova emulate ios not returning anything).

Permissions are checked and console.app does not say a thing to me.

So if anyone has a hint (anything I could try), I’d be really happy. Next step would be resetting my Mac and I would really(!) like to avoid this.

Switch to Node 4.2.2 and try it again. I ran into this a day or two ago when trying to use node v5.0.0. Downgrading fixed it for me.

@meyerbw Awesome!
Downgrading node solved the problem and was probably the only thing I hadn’t tried myself.

Thank you thank you thank you! :slight_smile: