Ionic Devapp always white screen


#1

Hi,

I tried using an ongoing project within Ionic Devapp. It’s supposed to load your app so you can view it. Except it’s always a blank screen when it loads up my project.

So, I tried making a completely new project with everything updated. I started with a blank project. Then I opened the blank project which is supposed to open to a single page with some text on it. It works in my browser but on in the ionic devapp. Does the DevApp work?


#2

I have exactly the same issue. I have always a blank page in devApp.


#3

DevApp is working fine for lots of people.


#4

I suppose that it works fine. I just want to fined where I can fine the issue I have.
It’s a copy of my console log:
dev server running: http://localhost:8100/

[OK] Development server running!
Local: http://localhost:8100
External: http://XXXXXX
DevApp: recipeBook@8100 on iMac-de-Patrick.local

[11:42:15] console.log: Angular is running in the development mode. Call enableProdMode() to enable the production
mode.
[11:42:15] console.warn: Native: tried calling StatusBar.styleDefault, but Cordova is not available. Make sure to
include cordova.js or run in a device/simulator
[11:42:15] console.warn: Native: tried calling SplashScreen.hide, but Cordova is not available. Make sure to include
cordova.js or run in a device/simulator
[11:42:16] lint finished in 1.94 s

Is there something wrong?


#5

this is a common warning, i get it all the time.

i haven’t found where this has gotten in the way or working

reference
https://github.com/ionic-team/ionic-cli/issues/259


#6

Not with that output.

Your app works in the browser?


#7

Yes in the browser it works perfectly and if I use Xcode too it works on my phone.


#8

What is your ionic info output?
Using any native plugins?


#9

My ionic info output:
cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

@ionic/app-scripts : 3.1.4
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.9.2

System:

ios-deploy : 1.9.2
Node       : v6.9.1
npm        : 3.10.8
OS         : macOS High Sierra
Xcode      : Xcode 9.2 Build version 9C40b

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

I haven’t add any plugin


#10

Same issue here
ionic info

cli packages:

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

local packages:

@ionic/app-scripts : 3.1.4
Ionic Framework    : ionic-angular 3.9.2

System:

Node : v6.10.2
npm  : 5.6.0
OS   : Windows 10

Misc:

backend : pro

#11

I had a similar issue on Windows 10, when running the Ionic CLI using Linux for Windows 10 (“Bash on Ubuntu”).

The issue was due to firewall rules in Windows 10 not allowing port 8100 (the port “ionic serve” runs on)

I fixed it by enabling port 8100 inside my firewall rules (TCP).
If you’re serving on a different port, just use that instead.

Just open Windows Defender Firewall, create “New Rule”, pick “Port”, put TCP port 8100, pick “Allow the connection”, pick the type of network (probably want it only allowed on Private and Domain networks), give it a name and it should start working.