Ionic cordova build android not creating apk file

On giveing the ionic cordova build android, number of instructions start runing on screen and after 100% completion, it does not create the apk file neither it show any error. it show following output

chunk {hardware-back-button-5afe3cb0-js} hardware-back-button-5afe3cb0-js-es5.js, (hardware-back-button-5afe3cb0-js) 2.88 kB [rendered]
chunk {home-home-module} home-home-module-es5.js, (home-home-module) 5.07 kB [rendered]
chunk {index-69c37885-js} index-69c37885-js-es5.js, (index-69c37885-js) 41.9 kB [rendered]
chunk {input-shims-a4fc53ac-js} input-shims-a4fc53ac-js-es5.js, (input-shims-a4fc53ac-js) 13.5 kB [rendered]
chunk {ios-transition-504cdd09-js} ios-transition-504cdd09-js-es5.js, (ios-transition-504cdd09-js) 26.6 kB [rendered]
chunk {main} main-es5.js, (main) 23.1 kB [initial] [rendered]
chunk {md-transition-fea2bbfb-js} md-transition-fea2bbfb-js-es5.js, (md-transition-fea2bbfb-js) 3.91 kB [rendered]
chunk {polyfills} polyfills-es5.js, (polyfills) 645 kB [initial] [rendered]
chunk {runtime} runtime-es5.js, (runtime) 9.71 kB [entry] [rendered]
chunk {shadow-css-4889ae62-23996f3f-js} shadow-css-4889ae62-23996f3f-js-es5.js, (shadow-css-4889ae62-23996f3f-js) 15.7 kB [rendered]
chunk {status-tap-32c72c43-js} status-tap-32c72c43-js-es5.js, (status-tap-32c72c43-js) 1.83 kB [rendered]
chunk {styles} styles-es5.js, (styles) 109 kB [initial] [rendered]
chunk {swipe-back-35ad8e37-js} swipe-back-35ad8e37-js-es5.js, (swipe-back-35ad8e37-js) 2.68 kB [rendered]
chunk {swiper-bundle-ccdaac54-js} swiper-bundle-ccdaac54-js-es5.js, (swiper-bundle-ccdaac54-js) 210 kB [rendered]
chunk {tap-click-ca00ce7f-js} tap-click-ca00ce7f-js-es5.js, (tap-click-ca00ce7f-js) 6.32 kB [rendered]
chunk {vendor} vendor-es5.js, (vendor) 4.59 MB [initial] [rendered]
Date: 2020-01-10T16:04:18.537Z - Hash: 0a1ee5e850134b7d84e5 - Time: 49688ms (After this line it does nothing)


Ionic CLI : 5.4.13 (C:\Users\Sasr Singh\AppData\Roaming\npm\node_modules\ionic)
Ionic Framework : @ionic/angular 4.11.7
@angular-devkit/build-angular : 0.801.3
@angular-devkit/schematics : 8.1.3
@angular/cli : 8.1.3
@ionic/angular-toolkit : 2.1.1


Cordova CLI : 9.0.0 (cordova-lib@9.0.1)
Cordova Platforms : android
Cordova Plugins : no whitelisted plugins (0 plugins total)


cordova-res : not installed
native-run : not installed


NodeJS : v12.14.1 (G:\Program Files\nodejs\node.exe)
npm : 6.13.4
OS : Windows 10

Hi I have the same issue for the last couple of days. It build earlier without any issues.
I have this issue when i build ionic 1 and ionic 4 app, which made me think if it is something related to my system or due to updating cordova to 9.0.0. So i tried building the apps on another system?. It works fine in the second system. So i think this is related to system heap. but i can’t figure out a way to overcome this. Any solution?

Hi sahibsingh,
after scratching my head for almost 3d, i finally found the solution.

When i tried building on the second system,my environment path for java home showed error. i corrected it at that time without looking at the version number. When i cross checked both builds, i found out that i am having an older version of jdk on my first system
The issue was caused by java. I had jdk8u231 installed on my system. Around 2 weeks ago jdk8u241 was released.I uninstalled my previous versions of jdk and jre and installed the new version and now my build works fine. My other system has automatic update turned on, so it already got the update on connecting to wifi.
I suggest you try the same. Uninstall java from control panel->programs andinstall the latest version of jdk. Make sure to correct the environment variable and restart the system before building app again


Hi Rahul,
The same error I found for me ionic cordova build android and it stucks at vendor is.
I tried with your solution but it’s not working for me.
Any other solutions please let me know.
Thanks in advance.

Hi sahibsingh,
Did you find the solution for this.

did you try reinstalling node modules and plugin

Yes, I reinstalled the node modules & plugin, Android platform

My problem is solved when i studied the android requirements page. Install the same Android platforms, jdk which is mentioned in the andriod requirements pages. if you are using any thing latest like latest jdk or anything, u r cordova will not build the apk file. In my case i was using the latest jdk which is not supported by cordova 9. So install everything same to same which is mentioned in ionic android requirements page. i am giving the link here.

hy i have also seme issue for the last 3 to 4 day .

my configration @sahibsingh

ionic info


Ionic CLI : 5.4.16 (C:\Users\l\AppData\Roaming\npm\node_modules\ionic)
Ionic Framework : @ionic/angular 5.0.7
@angular-devkit/build-angular : 0.803.26
@angular-devkit/schematics : 8.3.26
@angular/cli : 8.3.26
@ionic/angular-toolkit : 2.2.0


Cordova CLI : 9.0.0 (cordova-lib@9.0.1)
Cordova Platforms : android 8.1.0
Cordova Plugins : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 4.2.1, (and 4 other plugins)


cordova-res : 0.14.0
native-run : 1.0.0


Android SDK Tools : 26.1.1 (C:\Users\l\AppData\Local\Android\Sdk)
NodeJS : v12.16.2 (C:\Program Files\nodejs\node.exe)
npm : 6.14.4
OS : Windows 10

hy @sahibsingh any solution for this problem in my system ionic cordova build android -l work properly
but i need custom output to run ionic cordova build android then code create bundle perfectly but stop at

PS F:\nish\apk> ionic cordova run android
[INFO] Hardware device(s) found for android. Using --device.

ng.cmd run app:ionic-cordova-build --platform=android
Generating ES5 bundles for differential loading…
ES5 bundle generation complete.

many line of code…
chunk {vendor} vendor-es2015.js, (vendor) 4.48 MB [initial] [rendered]
chunk {vendor} vendor-es5.js, (vendor) 5.39 MB [initial] [rendered]
chunk {cordova} cordova.js, (cordova) 63.5 kB [entry] [rendered]
Date: 2020-05-14T08:45:10.219Z - Hash: 247cc0e42e352e57e7fd - Time: 93498ms

i need solution please help

i struck withthe same issue from past two days please any one help me overcome this issue?

when i execute the command
ionic cordova build android, the execution stops here and i cant build the apk file.
please suggest me what is this issue