Ionic CLI error on getting start


#1

Hi Guys,

I just follow the guide as :

Creating an Ionic 2.x app in /home/tpadmin/tony/tony/myApp based on the sidemenu template.

Downloading: https://github.com/driftyco/ionic2-app-base/archive/master.zip
Downloading: https://github.com/driftyco/ionic2-starter-sidemenu/archive/master.zip
Installing npm packages (may take a minute or two)…
Error with start undefined
Error Initializing app: There was an error with the spawned command: npminstall
There was an error with the spawned command: npminstall

in npm-debug.log:

593 silly rollbackFailedOptional Finishing
594 silly runTopLevelLifecycles Finishing
595 silly install printInstalled
596 verbose stack Error: No compatible version found: ionicons@3.0.0
596 verbose stack Valid install targets:
596 verbose stack 2.0.0
596 verbose stack
596 verbose stack at pickVersionFromRegistryDocument (/usr/lib/node_modules/npm/lib/fetch-package-metadata.js:178:16)
596 verbose stack at /usr/lib/node_modules/npm/node_modules/iferr/index.js:13:50
596 verbose stack at /usr/lib/node_modules/npm/lib/utils/pulse-till-done.js:20:8
596 verbose stack at saved (/usr/lib/node_modules/npm/lib/cache/caching-client.js:174:7)
596 verbose stack at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:241:18
596 verbose stack at FSReqWrap.oncomplete (fs.js:123:15)
597 verbose cwd /home/tpadmin/tony/tony/myApp
598 error Linux 3.16.0-4-amd64
599 error argv “/usr/bin/nodejs” “/usr/bin/npm” "install"
600 error node v6.9.4
601 error npm v3.10.10
602 error code ETARGET
603 error notarget No compatible version found: ionicons@3.0.0
603 error notarget Valid install targets:
603 error notarget 2.0.0
604 error notarget This is most likely not a problem with npm itself.
604 error notarget In most cases you or one of your dependencies are requesting
604 error notarget a package version that doesn’t exist.
604 error notarget
604 error notarget It was specified as a dependency of ‘ionic-app-base’

I am using nodejs 6.9.4 and npm 3.10.10

anything which i did wrong here?

Cheers,

-Y


#2

No one knows about this? or nobody ever starrt a new project?


#3

Creating a new project works fine for me. Do you always get the same error if you try again? Maybe it was just a temporary network problem or something.


#4

hi mirkonasato,

i tried it multiple times and everytime, i get the same error message above. i am not sure if it got to do with network in my office. however, it really has network issue, not sure why other dependecies got downloaded from npm repo.

just to precisely, i start from empty folder and it failed, i removed the created folder and re-run the same command again …

kinda puzzling…


#5

Failes with the same error for me too. However, I started the command prompt with elevated privileges, and ran npm install in the same directory where installation failed. It installed all the node modules and the app also worked. But I am still not able to create a new app in one go using ionic start AppName blank --v2.


#6

update your nodejs to recent version it may help you


#7

Updated to the latest version, did not help.


#8

@samarthagarwal @tonytony1 have you try to update everything (your nodejs, npm, ionic)? I previously had this kind of problem. I kinda reinstall anything (npm uninstall and install again to latest version) and everything works again


#9

Hi Guys,

i tried and actually, i just fresh install my nodejs (v.6.9.4 shipped with npm 3.10.10), ionic v.2.2.1 and cordova v.6.5.0 …

i still have the same problems.

not sure why…

for angular 1 project, it just works from the CLI getting started.

Cheers,

-Y