Ionic capacitor run ios -l --external won't run (no error)

I’m having a weird issue with capacitor where when I try to run my app on an external device it doesn’t run.

The device I’m trying to run my app on is iPhone 12 / iOS 15.4.1 (been doing this for a long time without an issue)

I get no error and the last lines in console are:

[capacitor] :heavy_check_mark: Running xcodebuild in 14.71s
[capacitor] :heavy_check_mark: Deploying Foodie Syndicate.app to device-id-here in 854.58ms

[INFO] App deployed to device!

   Development server will continue running until manually stopped.
   
   Use Ctrl+C to quit this process

If I run it on a simulator then it does work correctly and if I run it directly from Xcode to the physical device it will also work but not when I try to run it on a physical device using ionic capacitor run ios -l --external.

I’ve checked the device ID and it is correct, what could be the problem here?

My ionic info:

Ionic:

Ionic CLI : 6.19.0 (/Users/mindaugas/.config/yarn/global/node_modules/@ionic/cli)
Ionic Framework : @ionic/vue 6.0.14

Capacitor:

Capacitor CLI : 3.4.3
@capacitor/android : 3.4.3
@capacitor/core : 3.4.3
@capacitor/ios : 3.4.3

Utility:

cordova-res : not installed globally
native-run : 1.5.0

System:

NodeJS : v17.7.2 (/Users/mindaugas/.nodenv/versions/17.7.2/bin/node)
npm : 8.5.2
OS : macOS Monterey

Do you get any errors if you run native-run directly?

No. The command is finished after ~1sec. and that’s it.

Figured it out! It was NodeJS v17.7.2. I downgraded to v16.14.2 and now it is deploying correctly.