Ionic build --prod Get Stuck

if i try to create a production build for my ionic PWA app or any app it will get STuck on
Generating browser application bundles (phase: building)… and it wont give any error or pass here.
I have been experiencing this issue for a while now at first i thought it was my development enviroment i had to even change systems and use another one. i am still facing the same issue please i need help

here is my ionic info


Ionic CLI : 6.20.1 (C:\Users\HP\AppData\Roaming\npm\node_modules@ionic\cli)
Ionic Framework : @ionic/angular 6.1.8
@angular-devkit/build-angular : 13.2.6
@angular-devkit/schematics : 13.2.6
@angular/cli : 13.2.6
@ionic/angular-toolkit : 6.1.0


Capacitor CLI : 3.5.1
@capacitor/android : not installed
@capacitor/core : 3.5.1
@capacitor/ios : not installed


cordova-res : not installed globally
native-run : 1.6.0


NodeJS : v16.17.0 (C:\Program Files\nodejs\node.exe)
npm : 8.15.0
OS : Windows 10

D:\mydev\kashout>ionic build --prod

ng.cmd run app:build:production
\ Generating browser application bundles (phase: building)…

It remains Like this forever but i am able to just build normally but one i add --prod it will get Stuck here

Here is the Command with the --verbose Option

> D:\mydev\kashout>ionic build --prod --verbose
>   ionic:lib Terminal info: { ci: false, shell: 'C:\\Windows\\system32\\cmd.exe', tty: true, windows: true } +0ms
>   ionic:lib CLI global options: { _: [ 'build' ], help: null, h: null, verbose: true, quiet: null, interactive: true, color: true, confirm: null, json: null, prod: true, project: null, '--': [] } +4ms
>   ionic:lib:project Project type from config: @ionic/angular (angular) +0ms
>   ionic:lib:project Project details: { context: 'app', type: 'angular', errors: [], configPath: 'D:\\mydev\\kashout\\ionic.config.json' } +1ms
>   ionic Context: { binPath: 'C:\\Users\\HP\\AppData\\Roaming\\npm\\node_modules\\@ionic\\cli\\bin\\ionic', libPath: 'C:\\Users\\HP\\AppData\\Roaming\\npm\\node_modules\\@ionic\\cli', execPath: 'D:\\mydev\\kashout', version: '6.20.1' } +0ms
>   ionic:lib:build build options: {
>   ionic:lib:build   '--': [],
>   ionic:lib:build   engine: 'browser',
>   ionic:lib:build   platform: undefined,
>   ionic:lib:build   project: 'app',
>   ionic:lib:build   verbose: true,
>   ionic:lib:build   configuration: 'production',
>   ionic:lib:build   sourcemaps: undefined,
>   ionic:lib:build   cordovaAssets: true,
>   ionic:lib:build   watch: undefined,
>   ionic:lib:build   type: 'angular'
>   ionic:lib:build } +0ms
>   ionic:lib:telemetry Sending telemetry for command: 'ionic build' [ '--prod', '--verbose', '--interactive', '--color' ] +0ms
>   ionic:lib:hooks Looking for ionic:build:before npm script. +0ms
>   ionic:lib:build Looking for ionic:build npm script. +17ms
> > ng.cmd run app:build:production --verbose
>   ng:analytics getGlobalAnalytics +0ms
>   ng:analytics Client Analytics config found: false +5ms
>   ng:analytics Analytics disabled. Ignoring all analytics. +1ms
>   ng:analytics getSharedAnalytics +1ms
> \ Generating browser application bundles (phase: setup)...<t> [webpack.cache.PackFileCacheStrategy] restore cache container: 35.7646 ms
> \ Generating browser application bundles (phase: building)...

for how long have you tried to wait?
Are you behind a vpn or company network?

its my Local system and not behind any VPN or PROXY just my standalone system. the last time i waited 2hrs

ok, have you tried to run a blank new project and see if happens the same?
If not, you can start adding your plugins one by one and see what happens if you run the build

1 Like

Yeah During My Trouble Shooting process thats Exactly What i did. I created a blank project and its same on --prod. i can Build normally but just with this --prod flag

the only things that you can check are the dependencies and your node version, maybe someone else can help you :frowning:

After a few try Recreating a fresh Project Solved the issue Thanks