Ionic App not Working on IOS device

Hi everyone,
i’m currently trying to build my app for the App store.
My app is Working fine on Android in Chrome and even on all the IOS Simulators, but if i install it on my device through Xcode i just get a white screen after the splashscreen. Also tried runnig it with ionic cli. Same issue.
I don’t get any errors in Xcode.
I’m also not able to debug with Safari because the device doesn’t show up in the dev menu.
Also worth to note, that I’m using ionic deploy. But it is working great on Android and IOS Sim.
Any Ideas?

1 Like

What is the device console in Xcode telling you?

2015-11-10 12:31:24.352 Swapd[959:60b] Apache Cordova native platform version 3.9.2 is starting.
2015-11-10 12:31:24.360 Swapd[959:60b] Multi-tasking -> Device: YES, App: YES
2015-11-10 12:31:24.394 Swapd[959:60b] Unlimited access to network resources
2015-11-10 12:31:24.430 Swapd[959:60b] Fix applied for database locations?: YES
2015-11-10 12:31:24.608 Swapd[959:60b] [CDVTimer][keyboard] 0.830948ms
2015-11-10 12:31:24.772 Swapd[959:60b] [CDVTimer][splashscreen] 161.005974ms
2015-11-10 12:31:24.806 Swapd[959:60b] [CDVTimer][statusbar] 30.705988ms
2015-11-10 12:31:24.817 Swapd[959:60b] VERSION LABEL: 0.0.2:1447155061:
2015-11-10 12:31:24.820 Swapd[959:60b] updating version label
2015-11-10 12:31:24.839 Swapd[959:60b] [CDVTimer][ionicdeploy] 30.563951ms
2015-11-10 12:31:24.849 Swapd[959:60b] [CDVTimer][file] 6.994963ms
2015-11-10 12:31:24.852 Swapd[959:60b] Init FacebookConnect Session
2015-11-10 12:31:24.873 Swapd[959:60b] [CDVTimer][facebookconnectplugin] 21.412969ms
2015-11-10 12:31:24.876 Swapd[959:60b] [CDVTimer][TotalPluginStartup] 268.893003ms
2015-11-10 12:31:25.537 Swapd[959:60b] Resetting plugins due to page load.
2015-11-10 12:31:25.540 Swapd[959:60b] uuid is: 
2015-11-10 12:31:25.542 Swapd[959:60b] ignore deploy
2015-11-10 12:31:25.544 Swapd[959:60b] ignore version: 
2015-11-10 12:31:27.252 Swapd[959:60b] Finished load of: file:///var/mobile/Applications/DC3077B8-5890-4A24-9613-F714675E5AFB/
2015-11-10 12:31:27.866 Swapd[959:60b] Ionic Core: plugins are ready

I think you should fix this first. The device not showing up and the app not being inspectable is sign of a deeper problem. Here is all the information you need: Remote Debug your Ionic App ·

1 Like

I completly forgot to enable web inspector on the device. Now safari debugging is working.
I get the following error:

I’m pretty certain, that these files are in my www though.

Probably something is blocking these requests.

Which version of iOS are you using? Same in real device as in emulator?

Device is ios 7.1 and emulator is 9.1. But last time i tested on 9.1 device i had the same issue. Don’t have a 9.1 device available right now.

Try to get a 7.1 emulator and see if it works there?

The old simulators don’t work on El Capitan. :confused:
Do you have another Idea? Could it be a problem with this new transport security stuff?

Yep, or whitelist. But better first really understand where the problem happens - that’s why I asked for the simulators.

Maybe post this question on Slack - - I read about such problems there quite often.

1 Like

Fixed it. It was a very dumb mistake…
For some reason the Simulators aren’t case sensetive and devices are.
I just had to rename those two files.
Thanks for the help!

1 Like