Ionic and Crosswalk: Splash Screen error


#7

Thanks, @mhartington. How can I follow up on this issue effectively?


#8

You can check out the repo

Or follow the cordova issue tracker.

https://issues.apache.org/jira/browse/CB/?selectedTab=com.atlassian.jira.jira-projects-plugin:summary-panel


#9

Thanks for the info @mhartington

Also waiting for this issue to be resolved. (Crosswalk is a win,… first problem i get stuck at)


#10

I believe that this is the pending issue to fix it
https://issues.apache.org/jira/browse/CB-7156


#11

May be we can combine with LAUNCHSCREEN ?


#12

I was thinking the same, but once we installed “crosswalk browser” on ionic, where can we modify that ?


#13

Its in “\platforms\android\org.apache.cordova.engine.crosswalk\xwalk_core_library”


#14

@cybernatic did you have any success using this method?


#15

Didnt tryed out yet… Im now playing with apis (vibration,notification) for emprove skills.


#16

Has there been any progress on this? I have the splash screen working in iOS and stock android webview but I need CrossWalk for performance reasons.


#17

What’s the issue you’re seeing? Splashscreen seems to be working fine for me


#18

There seems to be a workaround for this if you install the latest plugin from git. See Splashscreen on Android doesn't work (only showing white screen for 2 seconds)


#19

Yup that solution worked for me as well.
Did everything, followed every tutorials and codes but didnt get the splash screen

ALl you need to do is add the splash screen plugin from github directly :smiley:


#20

Hi,

I just updated to Ionic CLI 1.3.19 and now only a white screen is shown when my Android app loads.
I also tried to remove the Splashscreen plugin and add it again via the Github URL as suggested here.
But now my build fails with the following error:

:compileArmv7DebugJavaD:\work\kolli\platforms\android\src\org\apache\cordova\splashscreen\SplashScreen.java:307: error: package DialogInterface does not exist
new DialogInterface.OnCancelListener() {
                                       ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 error
 FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileArmv7DebugJava'.

Do you have any idea what the problem may be?

My system information:

OS: Windows 7 Home Premium SP1
Node Version: v0.10.38
Cordova CLI: 4.3.0
Ionic Version: 1.0.0-beta.13
Ionic CLI: 1.3.19

and cordova plugins:

com.appsee.plugin 2.1.3 "Appsee"
com.bunkerpalace.cordova.YoutubeVideoPlayer 1.0.1 "CordovaYoutubeVideoPlayer"
com.ionic.keyboard 1.0.3 "Keyboard"
com.phonegap.plugins.PushPlugin 2.4.0 "PushPlugin"
cordova-plugin-crosswalk-webview 1.0.1-dev "Crosswalk WebView Engine"
cordova-plugin-splashscreen 1.0.1-dev "Splashscreen"
nl.x-services.plugins.socialsharing 4.3.13 "SocialSharing"
org.apache.cordova.console 0.2.13-dev "Console"
org.apache.cordova.device 0.2.13 "Device"

Best regards,

kolli


#21

Ok, I now installed the InAppBrowser plugin again. Had to remove version 0.5.4 because of a conflict with Crosswalk, but with version 0.6.0 the build error is gone.

Now I see the splash screen for a few seconds, but then again the white screen and the app won’t load… :frowning:


#22

@kolli, it sounds like you are having the same symptoms that I was up until yesterday - perhaps your cause is the same as well…

Apparently the whitelist functionality has been split off into a plugin from Cordova. For many of us, it’s this missing whitelist that’s leading to the white screen / app not loading issue…

Adding the whitelist plugin directly as is described in this thread resolved the white screen issue for me: Crosswalk Integration Beta in Ionic CLI (v1.3.2)


#23

YES, that fixed it for me too :smiley:

Thanks a lot for showing me this!
And of course big props to @thebosz for figuring it out!


#24

Hi,

I’m having the same issue but can’t solve it while following the solutions mentioned here.
I have the following plugins installed:
cordova-plugin-crosswalk-webview 1.5.0 "Crosswalk WebView Engine"
cordova-plugin-inappbrowser 1.2.1-dev "InAppBrowser"
cordova-plugin-splashscreen 3.1.0 "Splashscreen"
cordova-plugin-whitelist 1.2.2-dev "Whitelist"
nl.x-services.plugins.insomnia 4.0.1 “Insomnia (prevent screen sleep)”

I removed and added whiltelist, splash, in appbrowser after adding the crosswalk support.

Any ideas?


#25

I’m having the same issue too.
I found many answers, but no lucky.

I found this page, but I’m not sure how to apply xwalk_launch_screen to manifest https://crosswalk-project.org/documentation/manifest/launch_screen.html

Ideas?


#26

i had to put the FadeSplashScreen configuration on my config.xml:
<preference name="FadeSplashScreen" value="false"/>

If it is not there the splash doesn’t work for me.
let me know if it helps.