Ionic 3 with platform add ios@6.0.0

my ionic info is

Ionic:

ionic (Ionic CLI) : 4.3.1
Ionic Framework : ionic-angular 3.9.6
@ionic/app-scripts : 3.2.1

Cordova:

cordova (Cordova CLI) : 9.0.0 (cordova-lib@9.0.1)
Cordova Platforms : ios1 6.0.0
Cordova Plugins : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 5.0.0, (and 26 other plugins)

System:

ios-sim : 8.0.2
NodeJS : v12.18.1 (/Users/admin/.nvm/versions/node/v12.18.1/bin/node)
npm : 6.14.5
OS : macOS
Xcode : Xcode 11.2.1 Build version 11B500

but still i get the error of

unable to load PlatformApi from platform. SyntaxError: Unexpected token …
Uncaught, unspecified “error” event. (The platform “ios” does not appear to be a valid cordova platform. It is missing API.js. ios not supported.)
any one can help me out this