Ionic 3 Could not find com.google.firebase:firebase-core:15.0.1


#1

I got this error when I try to run in android

Could not resolve all files for configuration ‘:app:debugCompileClasspath’.

Could not find com.google.firebase:firebase-core:15.0.1.
Searched in the following locations:
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/google/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/google/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/android/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Dell/AppData/Local/Android/Sdk/extras/android/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://jcenter.bintray.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://jcenter.bintray.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://maven.google.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://maven.google.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://repo1.maven.org/maven2/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://repo1.maven.org/maven2/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/src/main/libs/firebase-core-15.0.1.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/src/main/libs/firebase-core.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/libs/firebase-core-15.0.1.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/libs/firebase-core.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/libs/firebase-core-15.0.1.jar
file:/C:/Users/Dell/Documents/IONIC/aplicativo/app-ionic/platforms/android/app/libs/firebase-core.jar
Required by:
project

I’m trying to use plugin Push :disappointed:


#2

BUILD FAILED in 5s
14 actionable tasks: 1 executed, 13 up-to-date
cmd: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • What went wrong:
    Could not resolve all files for configuration ‘:app:debugCompileClasspath’.

Could not find com.google.firebase:firebase-core:15.0.1.
Searched in the following locations:
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/google/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/google/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/android/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
file:/C:/Users/Vignesh/AppData/Local/Android/Sdk/extras/android/m2repository/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://maven.google.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://maven.google.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://jcenter.bintray.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://jcenter.bintray.com/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
https://repo1.maven.org/maven2/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.pom
https://repo1.maven.org/maven2/com/google/firebase/firebase-core/15.0.1/firebase-core-15.0.1.jar
file:/C:/Users/Vignesh/post-get - V140/platforms/android/app/src/main/libs/firebase-core-15.0.1.jar
file:/C:/Users/Vignesh/post-get - V140/platforms/android/app/src/main/libs/firebase-core.jar
file:/C:/Users/Vignesh/post-get - V140/platforms/android/app/libs/firebase-core-15.0.1.jar
file:/C:/Users/Vignesh/post-get - V140/platforms/android/app/libs/firebase-core.jar
Required by:
project :app

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

  • Get more help at https://help.gradle.org

BUILD FAILED in 5s
[ERROR] An error occurred while running subprocess cordova.

    cordova run android exited with exit code 1.

    Re-running this command with the --verbose flag may provide more information.