Ionic 2 Beta 7 Upgrade: The package rxjs@5.0.0-beta.8 does not satisfy its siblings' peerDependencies requirements!


#1

I am trying to upgrade the modules in existing project to Beta 7.

  1. I updated the package.json as follows:
	{
	  "dependencies": {
		"@angular/common": "^2.0.0-rc.1",
		"@angular/compiler": "^2.0.0-rc.1",
		"@angular/core": "^2.0.0-rc.1",
		"@angular/http": "^2.0.0-rc.1",
		"@angular/platform-browser": "^2.0.0-rc.1",
		"@angular/platform-browser-dynamic": "^2.0.0-rc.1",
		"@angular/router": "^2.0.0-rc.1",
		"es6-shim": "^0.35.0",
		"ionic-angular": "2.0.0-beta.7",
		"ionic-native": "^1.1.0",
		"ionicons": "3.0.0",
		"reflect-metadata": "^0.1.3",
		"rxjs": "^5.0.0-beta.6",
		"zone.js": "^0.6.12",
		"ng2-translate": "^1.11.1"
	  },
	  "devDependencies": {
		"del": "2.2.0",
		"gulp": "3.9.1",
		"gulp-watch": "4.3.5",
		"ionic-gulp-browserify-es2015": "^1.1.0",
		"ionic-gulp-fonts-copy": "^1.0.0",
		"ionic-gulp-html-copy": "^1.0.0",
		"ionic-gulp-sass-build": "^1.0.0",
		"ionic-gulp-scripts-copy": "^2.0.0",
		"run-sequence": "1.1.5"
	  },
	  "cordovaPlugins": [
		"cordova-plugin-device",
		"cordova-plugin-console",
		"cordova-plugin-whitelist",
		"cordova-plugin-splashscreen",
		"cordova-plugin-statusbar",
		"ionic-plugin-keyboard",
		"cordova-plugin-x-socialsharing",
		{
		  "locator": "https://github.com/katzer/cordova-plugin-local-notifications",
		  "id": "de.appplant.cordova.plugin.local-notification"
		},
		"cordova-plugin-admobpro",
		"cordova-plugin-app-version"
	  ],
	  "cordovaPlatforms": [
		"ios",
		{
		  "platform": "ios",
		  "version": "",
		  "locator": "ios"
		}
	  ],
	  "name": "latest",
	  "description": "latest: An Ionic project"
	}
  1. Removed npm_modules folder with rm -rf npm_modules

  2. And did npm install. This installs few modules and throws this error:

    npm ERR! peerinvalid The package rxjs@5.0.0-beta.8 does not satisfy its siblings’ peerDependencies requirements!

Any help?


#2

use it:

“rxjs”: “5.0.0-beta.6”,


#3

Thanks. That is resolved, but getting this:

npm ERR! peerinvalid The package reflect-metadata@0.1.3 does not satisfy its siblings' peerDependencies requirements!

Tried changing

"reflect-metadata": "^0.1.3", 

to

"reflect-metadata": "0.1.3", 

But it didn’t help! Any other suggestions?


#4

This worked:

"reflect-metadata": "0.1.2"