Invalid Signature iTunes Connect

#1

Heeey,

I’m having a trouble when I submitted my app to the App Store.
I received this mail from iTunes Connect:

Invalid Signature - A sealed resource is missing or invalid. The file at path [Enosis.app/Enosis] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose “Clean All” in Xcode, delete the “build” directory in the Finder, and rebuild your release target.

They speak about a .exec file (Enosis.app/Enosis) which is not properly signed.
But how can I sign it?
I have followed steps of Apple Dev website but It still not working.

Xcode: Version 9.0.1 (9A1004)
OS: macOS High Sierra

Can you please help
(sorry for my broken english)

#2

Hi Friend,

As per the message they want to convey that there is certificate issue is there please check either you are choosing development or ad-hoc one .While making IPA please choose correct certificate of distribution one.

thanks

#3

Thanks @chandelkushal,

Yep, I have choose the correct distribution certificate in Apple Dev website.
Run, build work perfectly whereas the submission don’t…

#4

I have the same error. Let me know if you find a solution :slight_smile:

#5

No problem, I keep you informed

#6

My provisioning profile seems to be Expired. I refreshed it but it doesnt seems to solve it?

#7

When you create your provisioning profile you have to select the good Apple ID.
Why do you have XC: Wildcard on your Provisioning profile name?

#8

Any progress @Hexago ? Ive been talking with apple on the phone and they told me they should investigate it on their side because everything seems right on my side…

1 Like
#9

Nothing new here…
I will call Apple French support this afternoon.
I keep you informed

1 Like
#10

@tobbe I have called the Apple support yesterday and they told me that the problem was on my side.
So I followed new rules and create one more time all my certificates but it still not working.

I’m lost, and I don’t understand anything about this certificate problem.

#11

@Hexago Apple basiclly said the same to me. They also gave me this link: https://developer.apple.com/library/content/qa/qa1510/_index.html I tried it but it didnt help.

Im totally lost to… :frowning: I’ve uploaded builds from another app from the same computer/account today and it worked like a charm…

#12

Hey @Hexago and @tobbe, did you find any solution?

#13

I found the problem! I had in my assets a file with a “ç” character.

1 Like
#14

@tobbe @Hexago In my case this error is generated by the format of my SSD on my MAC, which is APFS, the solution was to save the project folder on a USB drive with HPFS+ format. The solution can be found in this Apple Developer forum by user @jacargentina: https://forums.developer.apple.com/thread/89187

Apparently this problem with the SSD only occurs in ionic, in react native there are no problems of this type.