Installation


#1

Hi,

I wrote some apps that worked fine in the browser mode (serve). Now I want to show the “real” thing (ok, emulate) but I can’t get that going. After going back to nodejs v6.9.1 I also re-installed Android Studio, included the JAVA_HOME to c:\program files\java\jdk1.8.0_102\bin, and ANDROID_HOME to C:\Program Files\Android\Android Studio\bin.

I’m pretty much at a loss, so anyone a suggestion on what to re-install and or debug?

cheers,

Andreas


#2

For completeness, it is the tutorial MyIonicApp application


#3

Do you have an error/warning message during the build ? Or is the problem in the app ?


#4

It’s the standard tutorial app, MyIonicProject. So it’s not the code (serve also works fine). Warnings were during the build, but I couldn’t make much out of it. I’m now re-installing everything (node.js latest, ionic, cordova, android studio).
I found a difference here, the SDK is in a different location than my path variable. See if that’s the cause, I’ll keep the community posted


#5
  • you have to add the android platform with the command : cordova platform add android
  • activate on your mobile debug USB port
  • and connect you mobibe via USB
  • and the command : ionic run android --device

#6

Hi,

making progress, but still not 100%. I do the following

ionic emulate android

  • success, "build prod finished in 57.05s
  • running command: MyIonicProject\hooks\after_prepare\010_add_platform.js
    error messages:
  • add to body class: platform-android
  • JAVA_HOME is invalid

I understand the 2nd error message, but the first one is not clear. I have to import platform-android somewhere?

thanks,

Andreas


#7

when you execute this command “cordova platform add android” it creates a directory “platforms” and a sub directory “android”