Inputs don't work in app


#1

Hello!

I’m struggling to get some inputs to function when I transfer my app to my phone using PhoneGap. On my laptop it works fine. Here is the code for login.html:

<ion-view hide-nav-bar="true" hide-back-button="true" class="login">
<ion-content has-header="false" padding="false">

	<div class="login-container">

		<div class="logo">
			<h1>App</h1>
		</div>

		<div class="list">
			<input type="text" class="field top" name="username" ng-model="username" placeholder="Username">
			<input type="password" class="field" name="password" ng-model="password" placeholder="Password">
			<button class="button bot" ng-click="login()">Login</button>
		</div>

	</div>

</ion-content>

Is there any reason why this wouldn’t work? At the moment, everything appears on the screen but nothing is functional. Nothing happens when I tap on the fields or the button.

If this HTML seems like it would work completely, then perhaps there’s something going wrong in the JavaScript which I’ll need to debug my code for.

Thanks for the help!


#2

I know on mobile, there are input issues with you can’t target them unless they’re wrapped around a label. Try using this.

 <label class="item item-input">
    <input type="text" placeholder="First Name">
  </label>

#3

Thanks for your reply!
I tried this but it still doesn’t work on my phone (running Android 2.3). It works fine on an emulator and a friend’s phone, both running version 4+. Do you think this is a problem with PhoneGap?

Many thanks


#4

Hmm, in the ionic css, look for this property

-webkit-user-select: none;

Then give it a try on android. I did some quick research and saw this question on stack overflow, though it is for an older version of phonegap.


#5

Thanks for your reply. I’ve tried deleting this line each time it’s written in ionic.css, but it still doesn’t seem to work.

In the stackoverflow question, it seems they have a slightly different problem too. When I try to click on an input or button, literally nothing happens. The inputs or buttons don’t change state (:focus, :active etc), the keyboard doesn’t pop up, nothing.

As mentioned, any help with this would be really appreciated. I’m a bit stuck!


#6

Hey sorry for the wait. There are multiple issue for this right now, and the devs are working on trying to get this wrapped up. Until it’s resolved, your best bet is to sit tight and hold on.

You can track the status of tap/input issues here


#7

Thanks for the reply! I’ll be keeping track.