Icons broken in 4 rc 1

Hi,
If anyone else encounters an issue with broken icons after upgrading to 4.0 rc 1 the angular.json file has changed and needs the following. Even then I still seem to be having trouble with many svg icons not showing (fab buttons etc) :

"assets": [
              {
                "glob": "**/*",
                "input": "src/assets",
                "output": "assets"
              },
              {
                "glob": "**/*.svg",
                "input": "node_modules/ionicons/dist/ionicons/svg",
                "output": "./svg"
              }
            ],
9 Likes

Hi, thank you for this post. I had the same problem. :slight_smile:

Same problem, just few icons works.

Now, all my icons are all working again. I did nothing more than the above mentioned fix in the angular.json. Maybe because I cleaned and redeployed everything?! First, only a few icons were working.

1 Like

Hi thanks for this. We find same icons in “node_modules/@ionic/core/dist/ionic/svg” (ionic 4.0 rc0)

So which is the best to use ?

Same problem. How can I solve it?

What do you mean with clean and redeploy? I deleted the www folder, but problem still remains.

Yes, with “clean and redeploy” I meant to delete www folder. But I was wrong.

I found out, this was not the thing which helped. For me it makes a difference whether I run the app with livereload or without.

If I start my app via ionic cordova run android -l some icons are displayed, with ionic cordova run android all icons are displayed.

It worked for me, after a hit a non existing url http://localhost:8100/svg

1 Like

Hey, Is there an opened issue on github for that ?

Had the same problem. Look at the change log, it’s documented there. Need to do some changes in angular.json.

What I ended up doing was upgrading to rc1, start a new Ionic application and copying the angular.json file from there.

its described in detail here: https://github.com/ionic-team/ionic/blob/master/CHANGELOG.md#angularjson

i needed to readd platforms like
ionic cordova platform rm
ionic cordova platform add

and clear cache in browser to make it fully working.