$http get returning null data error


#1

i had this method as
$http({method: ‘GET’, url: url_to }).
and the success and error callbacks fine, now it only enters to the error, and the error its null.
its like http.get broken, i updated to latest beta 13, not sure, it seems this is more of angular maybe, i tried the usual even deleting all the platforms and installing all the plugins again but nothing, i am stuck here, any help appreciated if somebody had the same issue.

i tried changing it with promises, like this:

$http({method: ‘GET’, url: url_to }).then(function(data) {

but the same, this one trows me this if i print the data in the error callback:

{“data”:"",“status”:0,“config”:{“method”:“GET”,“transformRequ
est”:[null],“transformResponse”:[null],“url”:“https://example.com/api/customers?display=[id,email,firstname,lastname,passwd]&filter[emai
l]=someone@somewhere.com&filter[active]=1&filter[passwd]=4basdsdsadsadsad2994696b70c2”,“headers”:{“Accept”:“application/json, text/
plain, /”,“Authorization”:“Basic OEsssstYbladddd1asdsdasdsaOFMysdsd”}},“statusText”:""}

data null, why is it? it was working before…

if i make curl with it works fine


#2

$http requires MIME type adherence. I think the fresh Angular release has to do with this. But I am not sure. Please format your question properly.


#3

already working, i had this warning just before the call to the $http get

exec() call to SplashScreen.show blocked the main thread for 39ms. Plugin should use CordovaInterface.getThreadPool().

so i commented $cordovaSplashscreen.show(); and now its working.

now i have my slider images dowloaded , not calling them always from a webservice, thats fine. But when i open the slider and use my local files cdvfile i thought it will be much faster, but now so much slower its unusable, just to open a page it open it by blocks. but i will create another thread for this better.