How to use Range item?


#1

Hi
I have used range item in ionic. But in ionic2 I didnot find any range item. Does not ionic2 support range ???


#3

It isn’t implemented yet. :slight_smile: We have an open issue for it here:


#4

also waiting for it, thx
:thumbsup:

are there news?


#5

It’s currently being worked on and will be in the beta 8 release. :slight_smile:


#6

@brandyshea beta 8? I think now we are in beta 25? right?


#7

The latest release of the framework is beta 7 and the latest release of the CLI is beta 25. Please see this post for more information:

And our npm documentation:

Thanks!


#8

@brandyshea yea sorry! It was my mistake :slight_smile: beta.7 is clearly the last one! sorry

thx


#9

The framework vs CLI has caused a lot of confusion with them both being labeled beta. Hopefully we’ll have a final release of the CLI out soon so it won’t need the beta flag anymore. :slight_smile:

Make sure to check out our milestones on GitHub to see where we’re at with issues in each beta: https://github.com/driftyco/ionic/milestones


#10

okay thx, if for the range is this issue https://github.com/driftyco/ionic/issues/6019 it will be implemented in beta 9? right?


#11

That issue is just for adding vertical sliding, the other issue in beta 8 is to implement the range:


#12

@brandyshea okay thx a lot


#13

@brandyshea beta.8 now is out, are the range button implemented? I didn’t found nothing on v2 documentation.


#14

Yes: http://ionicframework.com/docs/v2/api/components/range/Range/

We haven’t updated the component docs to include it yet. The API docs are more thorough though.


#16

from which beta version it will work ? I m using beta.7.


#17

after command 'npm install ionic-angular@latest’
it giving below message

`-- ionic-angular@2.0.0-beta.8 invalid

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.12
npm WARN quranbd@ No repository field.
npm WARN quranbd@ No license field.


#18

It works with beta 8, we also posted a blog post about it: http://blog.ionic.io/ionic-2-beta-8-is-live/

The invalid is showing because that is not the version listed in your package.json. You can install it using the save flag:

npm install --save ionic-angular@latest

to make sure it gets saved in your package.json. Please make sure to check the changelog for steps to upgrade: https://github.com/driftyco/ionic/blob/2.0/CHANGELOG.md


#19