Help! Try to install does not work! Mac Catalina

owner@Owners-MacBook-Air ~ % npm install -g @ionic/cli

npm WARN checkPermissions Missing write access to /usr/local/lib/node_modules

npm ERR! code EACCES

npm ERR! syscall access

npm ERR! path /usr/local/lib/node_modules

npm ERR! errno -13

npm ERR! Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’

npm ERR! [Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’] {

npm ERR! stack: “Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’”,

npm ERR! errno: -13,

npm ERR! code: ‘EACCES’,

npm ERR! syscall: ‘access’,

npm ERR! path: ‘/usr/local/lib/node_modules’

npm ERR! }

npm ERR!

npm ERR! The operation was rejected by your operating system.

npm ERR! It is likely you do not have the permissions to access this file as the current user

npm ERR!

npm ERR! If you believe this might be a permissions issue, please double-check the

npm ERR! permissions of the file and its containing directories, or try running

npm ERR! the command again as root/Administrator.

npm ERR! A complete log of this run can be found in:

npm ERR! /Users/owner/.npm/_logs/2020-04-07T16_30_17_907Z-debug.log

owner@Owners-MacBook-Air ~ %

Before somebody suggests using sudo, please install nvm.

Thank you!
I tried the nvm and I got this message.

Sorry Im new here.

Last login: Tue Apr 7 15:17:15 on ttys000
owner@Owners-MacBook-Air ~ % command -v nvm
owner@Owners-MacBook-Air ~ % run
zsh: command not found: run
owner@Owners-MacBook-Air ~ % nvm install --lts
zsh: command not found: nvm
owner@Owners-MacBook-Air ~ % curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.34.0/install.sh | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 13226 100 13226 0 0 22842 0 --:–:-- --:–:-- --:–:-- 22803
=> nvm is already installed in /Users/owner/.nvm, trying to update using git
=> => Compressing and cleaning up git repository

=> Profile not found. Tried ~/.bashrc, ~/.bash_profile, ~/.zshrc, and ~/.profile.
=> Create one of them and run this script again
OR
=> Append the following lines to the correct file yourself:

export NVM_DIR="$HOME/.nvm"
[ -s “$NVM_DIR/nvm.sh” ] && . “$NVM_DIR/nvm.sh” # This loads nvm

=> Close and reopen your terminal to start using nvm or run the following to use it now:

export NVM_DIR="$HOME/.nvm"
[ -s “$NVM_DIR/nvm.sh” ] && . “$NVM_DIR/nvm.sh” # This loads nvm
owner@Owners-MacBook-Air ~ %
owner@Owners-MacBook-Air ~ %
owner@Owners-MacBook-Air ~ %
owner@Owners-MacBook-Air ~ %
owner@Owners-MacBook-Air ~ %

I don’t think I can improve on that message that is telling you how to update or create your shell’s profile file. Once you’ve done that, open a new terminal window and all should be well.