Hammer.min.js.map : Failed to load resource: the server responded with a status of 404 (Not Found) on iOS only


#1

when I am going to details page of my app, an error is coming and app comes on a kind of hang state, I cant go back, cant type, cant even scroll properly… error can be shown below:

this issue is coming on iOS only. Some one help me plz.


By mistake updated from ionic 3 to ionic 4 and now unable to go back to the ionic 3
#2

It seems it is not finding the .map file of hammer.min.js. The map file is used to map the js code that was built (minified, uglyfied, etc…) to the original code.

Hammerjs is mostly used by touch actions like tap and press. That error seems weird to be happening.

I don’t know if that is really the cause of your app hanging tough (map files are mostly for debug purposes).

I advise to you remove most code of your details page to see if the problem persists and, if the problem is over, add again what your removed from the page piece by piece to find out the source of the problem.

You can also try to remove the node_modules directory of your project and add it again running npm install in your project root directory.


#3

@lucasbasquerotto. Dear, I removed node_modules and run npm install command but it did not solve the issue. Will including hammer.min.js.map file in my project solve this issue? If yes, from where I can get hammer.min.js.map file AND if No, what else solution is there?


#4

@pantarmj Try to run in iOS with the --prod flag, because it doesn’t generate map files by default and the webview shouldn’t try to load it. See if it solves the 404 problem. Although, like I said, I don’t think the map file is the problem of the app hanging, buit you should give it a try.

ionic cordova run ios --prod


#5

when I am running “ionic cordova run ios --prod”, m getting following error:

and as I told you in my this ( By mistake updated from ionic 3 to ionic 4 and now unable to go back to the ionic 3 ) post, m running the run command by adding this ‘-- --buildFlag="-UseModernBuildSystem=0"’, the error after adding this command
‘ionic cordova run ios – --buildFlag="-UseModernBuildSystem=0" --prod’ is following:

plz help me, m stuck here since many days @lucasbasquerotto


#6

@lucasbasquerotto

Let me inform you that the issue is not about hanging but about tapping. When m tapping at one position it is getting tapped at other position or not getting tapped. And hence I m not able to interact with the app.


#7

I think that Hammerjs is used by ionic to handle touch actions like tap and press, so it makes sense if hammerjs is not correctly loaded. The problem is then: why it is not loaded? In android it works fine? You could ask the ionic team. Have you tried removing and adding again both the npm packages (node_modules) and the ios plugin? Then you tried to build again the app for iOS?


#8

@lucasbasquerotto

Yes, in android it is working fine. I deleted node_modules folder and run “npm install” but it did not solve the issue. How to remove plugin and re-install it?


#9

You can remove and add the plugin again with:

ionic cordova platform remove ios
ionic cordova platform add ios

If with the ionic cli you receive error you can install directly with cordova:

cordova platform remove ios
cordova platform add ios

After that build your app:

ionic cordova build ios

(or run drectly (with build included): ionic cordova run ios)

See if it solves your problem.


#10

It did not solve the problem dear. What else can I do?

@lucasbasquerotto


#11

@pantarmj What I think I would do in your case is create a blank ionic-v3 project and see if you can deploy it to ios.

I think the error you’re having shouldn’t happen, because using prod shouldn’t create nor load .map files.

So creating a blank project may make things easier to find the cause of the problem.

If it fails, then it’s probably some global package problem, like ionic (cli), cordova, npm or node.

If it works (it will probably work) then it’s probably some package conflict, plugin or configuration that is causing the problem.

To narrow down the problem, try to add your cordova plugins to the blank project and see if you can run in ios.

If it works, try to use the same package.json your project is using in the blank app (and run npm i).

Then, if it works again, copy the code inside the /src directory to the blank project (that won’t be blank anymore ^^).

So, you can use this approach to try to isolate the problem and find it’s cause.


#12

Solved:

404 error for hammer.min.js.map file was showing because of the below commented line in hammer.min.js file:

“//# sourceMappingURL=hammer.min.js.map”

just remove this line and the 404 error gone from console.

but this issue is not causing any problem in the app.