Google Play Services Version conflict


#1

Hello,

i tried to install the Google Maps and Firebase Cloud Messaging from the Ionic Native into one project using ionic 3 and cordova 6.3.0.

The Google maps Plugin uses
com.google.android.gms:play-services-maps:15.0.1

The FCM plugin uses
com.google.firebase:firebase-core:10.+
com.google.firebase:firebase-messaging:10.+

But when i understand it correctly the version numbers for the google play and firebase dependencies should be the same.

When I try to upgrade the FCM deps i get
Could not find com.google.firebase:firebase-messaging:15.0.1

When i try to upgrade the classpath com.google.gms:google-services:3.2.+ it won’t build and tells me my gradle version is too old. When trying to upgrade graddle to 3.+ cordova won’t compile anymore.

So this is a dilema. I cannot upgrade either of them to solve the issue.

Is there someway to use both plugins in the same project?


#2

#3

Yes my solution was to try out all the versions until it worked with version 12.

Took me some time but at least now it’s working.

That’s the downside of using 3rd party plugins instead of writing native code.

Thanks anyway!