First time building for iOS and errors as soon as I hit any of our API calls

Thanks a lot :slight_smile: Will check it out.

Is there perhaps something that needs to be enabled to make network requests allowed on iOS?

Perhaps added to config.xml?

Ensuring you are using HTTPS is the only thing I’m aware of.

cordova-plugin-wkwebview-engine ended up being the problem.

Once I updated it to the latest version everything worked without issue.

Thanks for the help @rapropos @Sujan12

1 Like

How exactly did you find out? Any indicators for the problem we could ask for the next time?

I created a new blank project and tested a http request which worked.

Then I tried the same request on our app and it failed. I compared the config.xml to see where it differed and I didnt really see anything.

I then found this iOS10 http requests blocked? and it gave me a push in the right direction.

I didnt want to remove WKWebView so I tried updating it and it worked without issue.

The main indicator is that it fails as soon as you make the http request and it gives a undefined and nothing else.

1 Like