Failed to build IONIC Geofence on XCode

#1

I am using Geofence plugin on IONIC. When i build on XCode 10.2 it’s say :

“Unsupported Swift Version. The target ‘MyApp’ contains source code developed with Swift 3.x. This version of Xcode does not support building or migrating Swift 3.x targets. Use Xcode 10.1 to migrate the code to Swift 4”

But if I downgrade to XCode 10.1, it will not work on iOS 12.2.

What should I do now? Any advice will be appreciated. Thanks.