Exit Code 1 and 8


#1

So I’ve been getting the exit codes 1 and 8 when doing “ionic run android”. Thing is, this was working perfectly fine a few days ago and now it is starting to throw this error each time I try to run my app on my Nexus 5. I had previously tried the AndroidInAppBilling plugin with no luck (anyone get inApp Billing working yet?) and ended up removing it thinking it was causing the error.

Error code 1 for command: cmd with args: /s,/c,ant,debug,-f,C:\xampp\htdocs\testapp\platforms\android\build.xml,-Dout.dir=ant-build,-Dgen.absolute.dir=ant-gen
Error: C:\xampp\htdocs\testapp\platforms\android\cordova\run.bat: Command failed with exit code 8
at ChildProcess.whenDone (C:\Users\Rudy\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:135:23)
at ChildProcess.EventEmitter.emit (events.js:98:17)
at maybeClose (child_process.js:753:16)
at Process.ChildProcess._handle.onexit (child_process.js:820:5)
ERROR: Unable to run app on platform android. Please see console for more info.
Exiting.

As for Ant, I did a version check: Apache Ant™ version 1.9.4 compiled on April 29 2014

Java version info: java version "1.8.0_11"
Java™ SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot™ 64-Bit Server VM (build 25.11-b03, mixed mode)

PATH also has the Android sdk and Ant values: C:\Ant\apache-ant-1.9.4\bin;C:\AndroidSDK\sdk\tools;C:\AndroidSDK\sdk\platform-tools

Forgot to mention I also tired “cordova platform rm android” and then added it again.

Anyone have any ideas?


#2

Ok so I was able to get this to work again. In my project directory, I did a command line “android” to launch the sdk manager. I went ahead and updated the sdk versions that were showing an update was available. After doing that, I tried both the run and build commands and both were successful. I also want to mention I had the Genymotion emulator running in the background while doing this so I’m not sure if that had anything to do with it but its worth a shot in case someone else is stuck with the same error.