ES6 Proxy Polyfill

I’m facing a problem when running on iOS9, it seems that its WebView doesn’t support new ES6 Proxy module… I’m using ng-http-interceptor library to intercept server calls (requests and responses) it’s really neat; however it uses the Proxy module which isn’t compatible for ES5 WebViews… How could I use the proxy-polyfill so that it can be compiled with the build?

1 Like

Hi @logus , were you able to solve this problem? I have exactly the same situation.

Nevermind, it’s easy:
npm install proxy-polyfill --save
and
import 'proxy-polyfill'; where you used ng-http-interceptor

1 Like