Error when trying to upgrade to 3.17.0


#1

Error when trying to upgrade to 3.17.0

After that error the “ionic” is not recognized in the command line.
I needed to re install the ionic with: npm install -g ionic cordova

Error:

Error
at ShellException.Exception (C:\Users\Dani\AppData\Roaming\npm\node_modules\ionic\node_modules@ionic\cli-utils\lib\errors.js:8:23)
at ShellException (C:\Users\Dani\AppData\Roaming\npm\node_modules\ionic\node_modules@ionic\cli-utils\lib\errors.js:26:9)
at ChildProcess.p.on.code (C:\Users\Dani\AppData\Roaming\npm\node_modules\ionic\node_modules@ionic\cli-utils\lib\utils\shell.js:68:28)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:194:7)
at ChildProcess.cp.emit (C:\Users\Dani\AppData\Roaming\npm\node_modules\ionic\node_modules\cross-spawn\lib\enoent.js:40:29)
at maybeClose (internal/child_process.js:899:16)
at Socket. (internal/child_process.js:342:11)
at emitOne (events.js:96:13)
at Socket.emit (events.js:191:7)