Error when building found version 4, expected 3

I am getting an error - Error: Metadata version mismatch for module /root/manappurammob/node_modules/ionic2-date-picker/src-inlined/date-picker.interface.d.ts, found version 4, expected 3, when I execute
ionic cordova build browser --prod
Without the --prod option, it works. But I would like to have aot enabled for better performance. My package.json is

{
"name": "paymetry-mobileweb",
"version": "0.0.1",
"author": "Ionic Framework",
"homepage": "http://ionicframework.com/",
"private": true,
"scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
},
"dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/clipboard": "^4.2.1",
    "@ionic-native/core": "3.12.1",
    "@ionic-native/splash-screen": "3.12.1",
    "@ionic-native/status-bar": "3.12.1",
    "@ionic/storage": "2.0.1",
    "angular2-cookie": "^1.2.6",
    "cordova-browser": "^5.0.4",
    "cordova-clipboard": "^1.3.0",
    "cordova-plugin-console": "^1.1.0",
    "cordova-plugin-device": "^1.1.7",
    "cordova-plugin-splashscreen": "^4.1.0",
    "cordova-plugin-statusbar": "^2.4.3",
    "cordova-plugin-whitelist": "^1.3.4",
    "ion2-calendar": "^2.2.0",
    "ionic-plugin-keyboard": "^2.2.1",
    "ionic2-date-picker": "^1.1.3",
    "ionicons": "3.0.0",
    "ngx-cookie": "^1.0.0",
    "ngx-webstorage": "^1.8.0",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12"
},
"devDependencies": {
    "@angular/cli": "^1.3.2",
    "@ionic/app-scripts": "2.1.3",
    "ionic": "3.9.2",
    "ionic-angular": "^3.9.8",
    "typescript": "2.3.4"
},
"description": "An Ionic project",
"cordova": {
    "plugins": {
        "cordova-clipboard": {},
        "cordova-plugin-console": {},
        "cordova-plugin-device": {},
        "cordova-plugin-splashscreen": {},
        "cordova-plugin-statusbar": {},
        "cordova-plugin-whitelist": {},
        "ionic-plugin-keyboard": {}
    },
    "platforms": [
        "browser"
    ]
}  

I can’t tell you what exact version to pick, because everything else in this app is so old, but the major version of every @ionic-native dependency must be identical. You have mostly 3s, but one 4.