Error reading template file, "my-component-tpl.html"

I have cloned ionic-conference app and I am getting the following error on ‘ionic serve’

[16:09:23]  bundle dev started ...                                                                                                                                                             
Error reading template file, "my-component-tpl.html": Error: ENOENT: no such file or directory, open 'e:\2016\conf-app\node_modules\@ionic\storage\node_modules\@angular\core\src\animation\my-
component-tpl.html'                                                                                                                                                                            
                                                                                                                                                                                               
[16:09:29]  Error: Module e:\2016\conf-app\node_modules\rxjs\Subject.js does not export Subject (imported by e:\2016\conf-app\node_modules\@angular\core\src\facade\async.js)                  
    at Module.trace (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:7677:29)                                                                              
    at ModuleScope.findDeclaration (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:7300:22)                                                               
    at Identifier.bind (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:6489:29)                                                                           
    at e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5151:50                                                                                             
    at CallExpression.eachChild (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5165:19)                                                                  
    at CallExpression.bind (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5151:7)                                                                        
    at CallExpression.bind (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5842:23)                                                                       
    at e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5151:50                                                                                             
    at ParenthesizedExpression.eachChild (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5168:5)                                                          
    at ParenthesizedExpression.bind (e:\2016\conf-app\node_modules\@ionic\app-scripts\node_modules\rollup\dist\rollup.js:5151:7)                                                               
                                                                                                                                                                                               
[16:09:29]  sass started ...                                                                                                                                                                   
[16:09:31]  sass finished in 2.00 s                                                                                                                                                            
[16:09:31]  build dev failed:  Build failed
2 Likes

Did you already try to remove the node_modules and reinstalling them again yourself?

Yes. I did @luukschoen. Then the new error I was getting was: No providers for PlatformLocation.
I did just another attempt and before that I found some how my vscode was still using Typescript 1.8.
And I updated typescript to 2.0 and it is working fine now.

Here are the steps followed:

  1. Deleted node_modules
  2. npm install typescript@2.0.0
  3. npm install

However the fonts are still missing for me. :frowning: