"Error: "PluginName" plugin is not implemented on ios" after Capacitor 6 update

We just updated our app to Capacitor 6. Everything appeared to have worked fine. The Android app is working fine. We have implemented a few custom plugins. These work fine on Android. The don’t work on iOS, we get this error: Error: "PluginName" plugin is not implemented on ios.

We tried running the troubleshooting steps mentioned here: iOS Troubleshooting Guide | Capacitor Documentation

Plugins that we installed through npm work fine. Only our custom plugins don’t work. We did follow this guide: Updating plugins to 6.0 | Capacitor Documentation as well as checked what other open source plugins changed (there haven’t been any major changes on iOS as far as I can see).

We are using SPM and have used SPM before the Capacitor 6 update. We don’t use SPM capacitor dependencies, only for dependencies we require for native iOS code (so we are using Pods + SPM and do so for several months).

Do you have any idea what we could try to fix this issue?

Ok, we found the issue, there was an undocumented change. It’s a bit weird that this has not been added to the docs yet :cry:.

1 Like