Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (57)


#1

Hello - does anyone know how to fix the following error?

bash-3.2# ionic serve -c
Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (57)
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.5.0
    at module.exports (/Users/richardparry/ionic apps/Ionic3WoocommerceBooking/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/Users/richardparry/ionic apps/Ionic3WoocommerceBooking/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (module.js:652:30)
    at Object.Module._extensions..js (module.js:663:10)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/Users/richardparry/ionic apps/Ionic3WoocommerceBooking/node_modules/@ionic/app-scripts/dist/core/bundle-components.js:6:16)

#2

What’s your ionic info and package.json?


#3

I am a newbie - sorry - can you let me know how i get this information please


#4

bash-3.2# ionic info

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 8.0.0 

local packages:

@ionic/app-scripts : 1.3.7
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.1.1

System:

Node  : v8.10.0
npm   : 5.6.0 
OS    : macOS High Sierra
Xcode : Xcode 9.2 Build version 9C40b 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

PACKAGE.JSON

{
“name”: “ionic-woo-booking”,
“author”: “Ionic Framework”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
@angular/common”: “4.0.2”,
@angular/compiler”: “4.0.2”,
@angular/compiler-cli”: “4.0.2”,
@angular/core”: “4.0.2”,
@angular/forms”: “4.0.2”,
@angular/http”: “4.0.2”,
@angular/platform-browser”: “4.0.2”,
@angular/platform-browser-dynamic”: “4.0.2”,
@ionic-native/core”: “3.4.2”,
@ionic-native/splash-screen”: “3.4.2”,
@ionic-native/status-bar”: “3.4.2”,
@ionic/storage”: “2.0.1”,
@ngx-translate/core”: “^6.0.1”,
@ngx-translate/http-loader”: “0.0.3”,
“cordova-ios”: “4.5.4”,
“crypto-js”: “^3.1.9-1”,
“ion-multi-picker”: “2.0.0”,
“ionic-angular”: “3.1.1”,
“ionic-native”: “2.9.0”,
“ionicons”: “3.0.0”,
“moment”: “2.17.1”,
“rxjs”: “5.1.1”,
“sw-toolbox”: “3.4.0”,
“zone.js”: “^0.8.20”
},
“devDependencies”: {
@ionic/app-scripts”: “1.3.7”,
“typescript”: “2.3.3”
},
“description”: “IonicWooAuction: An Ionic project”,
“cordovaPlugins”: [
“cordova-plugin-device”,
“cordova-plugin-console”,
“cordova-plugin-whitelist”,
“cordova-plugin-splashscreen”,
“cordova-plugin-statusbar”,
“ionic-plugin-keyboard”
],
“cordovaPlatforms”: []
}


#5

Your version of app-scripts is maybe 2 years old. Is this a legacy project?


#6

Yes it is - This app contains woocommerce booking api’s that I want to be able to connect my woocommerce store to an app


#7

There might be a lot of incompatibilities then. If you’re new, you’re probably better off building a few tutorials first. This sounds like a potential landmine. You might be a couple weeks away from being able to work on this project. Sorry.


#8

I looked up the version and it was released 4 May 2017. So, ten months ago. Would rather plough ahead.


#9

Well, you will have to downgrade your macOS then - because the one you are using just doesn’t seem to be supported by node-sass which is used by this very old app-scripts version.

Alternatively you might try to use https://update.ionic.zone to update the project, from Ionic 3.1.1 to a current version should not be too much work.


#10

Thank you I will try that.


#11

Solution:
$> npm rebuild node-sass

Or
$> npm uninstall node-sass && npm install node-sass
(again, with -g if necessary).

This problem occur when you change NodeJs version for example