Error in "ionic start myApp sidemenu"


#1

I’m getting the following error while trying to create a starter project. For some reason, the “ionic start myApp sidemenu” command fails when it calls “gulp sass”. Everything other task up to that point ran okay without errors.

gulp-sass@0.7.1 node_modules\gulp-sass
├── map-stream@0.1.0
├── gulp-util@2.2.14 (chalk@0.4.0, lodash._reinterpolate@2.4.1, dateformat@1.0.7-1.2.3, multipipe@0.0.2, minimist@0.0.8, vinyl@0.2.3, through2@0.4.1, lodash.template@2.4.1)
└── node-sass@0.8.3 (node-watch@0.3.4, chalk@0.3.0, nan@0.6.0, mkdirp@0.3.5, optimist@0.6.1, mocha@1.13.0)
[gulp] Using file c:\Users\dev\Code\git\myApp\gulpfile.js
[gulp] Working directory changed to c:\Users\dev\Code\git\myApp
gulp.run() has been deprecated. Use task dependencies or gulp.watch task trigger
ing instead.
[gulp] Running 'sass'...

stream.js:94
      throw er; // Unhandled stream error in pipe.
            ^
[←[32mgulp←[39m] Error in plugin '←[36mgulp-sass←[39m': source string:22: **error: file to import not found or unreadable: "www/lib/ionic/scss/ionic"**

    at opts.error (c:\Users\dev\Code\git\myApp\node_modules\gulp-sass\indexjs:67:17)

Looking inside the /myApp/www I do not see any /lib/ionic subfolders. Is there an error in the “start” scripts, or could this be an environmental issue on my part?


#2

Did you run bower install?


#3

I didn’t explicitly, but maybe the “ionic start” command does?

I followed the getting started 3-steps : http://ionicframework.com/getting-started/

npm install -g cordova
npm install -g ionic
npm start myApp sidemenu  <-- error at the end

#4

OK, I’ll look into it.


#5

@duuuudeman for the last line, you have npm start myApp sidemenu, that should be ionic start myApp sidemenu. Does it work then?


#6

I am also having issues with the ionic start myApp sidemenu.

I have followed the instructions and yet the app that is built is the Pets one. Am I missing some instructions?


#7

Travis, make sure to upgrade ionic:

sudo npm install -g ionic

You should see version 1.0.0-beta.1 come back from that command.


#8

@max thanks for the quick reply, that worked!


#9

Thanks Max for the correction. That was a typo on my part, sorry for any confusion.

Anyways. I just re-ran “ionic start myApp sidemenu” and this time it worked (no error messages)!
Either something has been fixed in the past 2 hours, or I forgot to take my crazy pills today.

Edit: no errors, however I still don’t see a /www/lib folder, created by this "start command. Should that be in there?


#10

@duuuudeman we found another problem with the instructions is it doesn’t tell you to install the gulp build tool before installing.

Try this to fix it:

  1. cd to your project folder.
  2. npm install -g gulp
  3. gulp init

#11

I just wanted to follow up and say that since running the following command ( see the getting started guide has been updated) that my issue has been resolved:

npm install -g cordova ionic bower gulp

I can now see the starter app! Thanks for your help.