Error : found moderate severity vulnerabilities!


#1

Hello,

For some time since I’m doing an update of a module, I have this error that appears … What should I do?

Error :
found 5 moderate severity vulnerabilities
run npm audit fix to fix them, or npm audit for details

npm audit fix tell me :
fixed 0 of 5 vulnerabilities in 13346 scanned packages
5 vulnerabilities required manual review and could not be updated

npm audit tell me :
Moderate Prototype pollution

Package hoek

Patched in > 4.2.0 < 5.0.0 || >= 5.0.3

Dependency of @ionic/app-scripts [dev]

Path @ionic/app-scripts > node-sass > request > hawk > boom >
hoek

More info https://nodesecurity.io/advisories/566

Moderate Prototype pollution

Package hoek

Patched in > 4.2.0 < 5.0.0 || >= 5.0.3

Dependency of @ionic/app-scripts [dev]

Path @ionic/app-scripts > node-sass > request > hawk > cryptiles
> boom > hoek

More info https://nodesecurity.io/advisories/566

Moderate Prototype pollution

Package hoek

Patched in > 4.2.0 < 5.0.0 || >= 5.0.3

Dependency of @ionic/app-scripts [dev]

Path @ionic/app-scripts > node-sass > request > hawk > hoek

More info https://nodesecurity.io/advisories/566

Moderate Prototype pollution

Package hoek

Patched in > 4.2.0 < 5.0.0 || >= 5.0.3

Dependency of @ionic/app-scripts [dev]

Path @ionic/app-scripts > node-sass > request > hawk > sntp >
hoek

More info https://nodesecurity.io/advisories/566

Moderate Memory Exposure

Package tunnel-agent

Patched in >=0.6.0

Dependency of @ionic/app-scripts [dev]

Path @ionic/app-scripts > node-sass > request > tunnel-agent

More info https://nodesecurity.io/advisories/598