[ERROR] Exception: Using cordova-fetch for cordova-ios


#1

Hello,
Someone can help me with this?
I don’t know what happened, I change the version of node and I get the same issue.

Sorry for my bad english and thank you!

Ionic info

cli packages: (/Users/---/.npm-packages/lib/node_modules)

    @ionic/cli-utils  : 1.12.0
    ionic (Ionic CLI) : 3.12.0

global packages:

    cordova (Cordova CLI) : 7.0.1 

local packages:

    @ionic/app-scripts : 2.1.4
    Cordova Platforms  : android 6.2.3
    Ionic Framework    : ionic-angular 3.6.1

System:

    Android SDK Tools : 26.1.1
    ios-deploy        : 1.9.2 
    ios-sim           : 5.0.13 
    Node              : v8.6.0
    npm               : 2.15.12 
    OS                : macOS Sierra
    Xcode             : Xcode 9.0 Build version 9A235 

Misc:

    backend : legacy

Image of problem


#2

Should you try ionic cordova platform add ios ?


#3

Yes, i just try ionic cordova platform add ios


#4

so you still get same error?


#5

I get this error from image above when i use ionic cordova platform add ios


#6

Maybe this link can help you https://stackoverflow.com/a/40935899/5147566
Answer is:
I think you have to issue with permission to add platform .
Try to following :
$sudo chown -R {user_name} /Users/{user_name}/.cordova/lib/npm_cache/
For more please check here.
Hopes this will help you !


#7

Thank you for try help me, but don’t work, =(


#8

My project install npm 2.15.12 inside, folder .bin
I try to remove npm inside and change for npm 5.3 from my folder usr/local/ after that works

I could see that when I use the npm install command it installs a local version of npm (old version) on .bin folder

Do you know why?

@drquochoai

Thanks


#9

Hi, i find solution to my problem Here

Cordova install outdated npm version.

Just install locally

npm install --save-dev npm@latest