Error during start my app by IONIC CLI 3


#1

Hello, today I install the Ionic CLI 3 on windows and try to run my application.
after enter the IP address I receive the following error.

TypeError: appScripts.serve is not a function

I run the update code by this blog post .
During the update i revceive teh message

You will need to install the following global dependencies in order to use this plugin.
npm install -g ios-deploy ios-sim

ionic-hello-world@ C:\my\path\mobile.dev
+-- UNMET PEER DEPENDENCY @ionic/app-scripts@1.0.0
+-- @ionic/cli-build-ionic-angular@0.0.3
`-- @ionic/cli-plugin-cordova@0.0.9

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN @ionic/cli-build-ionic-angular@0.0.3 requires a peer of @ionic/app-scripts@^1.1.0 but none was installed.

How can i fix this issue?


#2

I have updated the package.json

@ionic/app-scripts": "1.1.4"

Then npm install in the root folder of the project.

now it works.


#3

its perfectly work :relaxed: superb


#4

Hi

I needed to use 1.3.1 for the latest version of app-scripts.

Thx for the solution given.

npm WARN @ionic/cli-plugin-ionic-angular@1.0.0-rc.2 requires a peer of @ionic/ap
p-scripts@^1.3.1 but none was installed.
npm ERR! code 1

Tom


#5

That is far from “latest” either of app-scripts (2.0.2) or cli-plugin-ionic-angular (1.3.2).


#6

Execute this command:

npm install --save-dev @ionic/app-scripts@latest

After that your app should work using

ionic serve