[ERROR] An error occurred while running npm install (exit code 1):


#1

First sorry if this it is not the category for this, I know is a “Work enviroment” issue. I have two days trying to start with ionic, I was sleepy at the time I was installing node and I had a lot of troubles. I uninstall it and install it like 5 times then I installed ionic and tried to create a Project but. pfff :c this is the error.

✔ Creating directory /home/lightyagami/Documents/AndroidDev/myApp - done!
Fetching app base (https://github.com/driftyco/ionic2-app-base/archive/master.tar.gz)
✔ Downloading - done!
Fetching starter template tabs (https://github.com/driftyco/ionic2-starter-tabs/archive/master.tar.gz)
✔ Downloading - done!
✔ Updating package.json with app details - done!
✔ Creating configuration file ionic.config.json - done!
Installing dependencies may take several minutes!
> npm install
✖ Running command - failed!
[ERROR] An error occurred while running npm install (exit code 1):
        
        npm WARN deprecated object-keys@0.2.0: Please update to the latest object-keys
        npm WARN prefer global node-gyp@3.6.1 should be installed with -g
        
        > node-sass@4.5.0 install /home/lightyagami/Documents/AndroidDev/myApp/node_modules/node-sass
        > node scripts/install.js
        
        Downloading binary from https://github.com/sass/node-sass/releases/download/v4.5.0/linux-x64-48_binding.node
        Cannot download "https://github.com/sass/node-sass/releases/download/v4.5.0/linux-x64-48_binding.node": 
        
        ESOCKETTIMEDOUT
        
        Hint: If github.com is not accessible in your location
              try setting a proxy via HTTP_PROXY, e.g. 
        
              export HTTP_PROXY=http://example.com:1234
        
        or configure npm proxy via
        
              npm config set proxy http://example.com:8080
        
        > node-sass@4.5.0 postinstall /home/lightyagami/Documents/AndroidDev/myApp/node_modules/node-sass
        > node scripts/build.js
        
        Binary found at /home/lightyagami/Documents/AndroidDev/myApp/node_modules/node-sass/vendor/linux-x64-48/binding.node
        Testing binary
        Bus error (core dumped)
        myApp@0.0.1 /home/lightyagami/Documents/AndroidDev/myApp
        ├── @angular/common@4.1.0 
        ├── @angular/compiler@4.1.0 
        ├─┬ @angular/compiler-cli@4.1.0 
        │ ├─┬ @angular/tsc-wrapped@4.1.0 
        │ │ └─┬ tsickle@0.21.6 
        │ │   ├─┬ mkdirp@0.5.1 
        │ │   │ └── minimist@0.0.8 
        │ │   ├── source-map@0.5.6 
        │ │   └── source-map-support@0.4.15 
        │ ├── minimist@1.2.0 
        │ └── reflect-metadata@0.1.10 
        ├── @angular/core@4.1.0 
        ├── @angular/forms@4.1.0 
        ├── @angular/http@4.1.0 
        ├── @angular/platform-browser@4.1.0 
        ├── @angular/platform-browser-dynamic@4.1.0 
        ├── @ionic-native/core@3.7.0 
        ├── @ionic-native/splash-screen@3.7.0 
        ├── @ionic-native/status-bar@3.7.0 
        ├─┬ @ionic/storage@2.0.1 
        │ ├── @types/localforage@0.0.30 
        │ ├─┬ localforage@1.4.3 
        │ │ └─┬ lie@3.0.2 
        │ │   ├─┬ es3ify@0.1.4 
        │ │   │ ├── esprima-fb@3001.1.0-dev-harmony-fb 
        │ │   │ ├─┬ jstransform@3.0.0 
        │ │   │ │ ├── base62@0.1.1 
        │ │   │ │ └─┬ source-map@0.1.31 
        │ │   │ │   └── amdefine@1.0.1 
        │ │   │ └── through@2.3.8 
        │ │   ├── immediate@3.0.6 
        │ │   ├─┬ inline-process-browser@1.0.0 
        │ │   │ ├─┬ falafel@1.2.0 
        │ │   │ │ ├── acorn@1.2.2 
        │ │   │ │ ├── foreach@2.0.5 
        │ │   │ │ └── object-keys@1.0.11 
        │ │   │ └─┬ through2@0.6.5 
        │ │   │   ├─┬ readable-stream@1.0.34 
        │ │   │   │ ├── core-util-is@1.0.2 
        │ │   │   │ ├── inherits@2.0.3 
        │ │   │   │ └── string_decoder@0.10.31 
        │ │   │   └── xtend@4.0.1 
        │ │   └─┬ unreachable-branch-transform@0.3.0 
        │ │     ├── esmangle-evaluator@1.0.1 
        │ │     └─┬ recast@0.10.43 
        │ │       ├── ast-types@0.8.15 
        │ │       ├── esprima-fb@15001.1001.0-dev-harmony-fb 
        │ │       └── private@0.1.7 
        │ └── localforage-cordovasqlitedriver@1.5.0 
        ├── ansi-regex@2.1.1  extraneous
        ├── ansi-styles@2.2.1  extraneous
        ├── babel-code-frame@6.22.0  extraneous
        ├── babel-core@6.24.1  extraneous
        ├── ionic-angular@3.2.1 
        ├── ionicons@3.0.0 
        ├─┬ rxjs@5.1.1 
        │ └── symbol-observable@1.0.4 
        ├─┬ sw-toolbox@3.6.0 
        │ ├─┬ path-to-regexp@1.7.0 
        │ │ └── isarray@0.0.1 
        │ └── serviceworker-cache-polyfill@4.0.0 
        ├── typescript@2.2.1 
        └── zone.js@0.8.10 
        
        npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
        npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
        npm ERR! Linux 4.8.0-49-generic
        npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
        npm ERR! node v6.10.3
        npm ERR! npm  v3.10.10
        npm ERR! code ELIFECYCLE
        
        npm ERR! node-sass@4.5.0 postinstall: `node scripts/build.js`
        npm ERR! Exit status 135
        npm ERR! 
        npm ERR! Failed at the node-sass@4.5.0 postinstall script 'node scripts/build.js'.
        npm ERR! Make sure you have the latest version of node.js and npm installed.
        npm ERR! If you do, this is most likely a problem with the node-sass package,
        npm ERR! not with npm itself.
        npm ERR! Tell the author that this fails on your system:
        npm ERR!     node scripts/build.js
        npm ERR! You can get information on how to open an issue for this project with:
        npm ERR!     npm bugs node-sass
        npm ERR! Or if that isn't available, you can get their info via:
        npm ERR!     npm owner ls node-sass
        npm ERR! There is likely additional logging output above.
        
        npm ERR! Please include the following file with any support request:
        npm ERR!     /home/lightyagami/Documents/AndroidDev/myApp/npm-debug.log

PD: I had an .outoftime issue and I modified script.js (I think that was the name) and that fixed that error, but I mentioned just for the case is there a connection.


#2

Probably the fastest way to resolve this would be to find anybody else behind this proxy that is using npm, and asking them what they did.


#3

My mind was centered in search about the “NPM WARN’s” and you were right, the thing is I’m from Venezuela, so I thought, my repositories are located by default, near or in my country or well with a direction like ve.ubuntu, I changed to US and that is the fix for all… I feel stupid xD. Thanks dude!


#4

i have the same problem and i have open a topic for that

i have just started with ionic a week ago and i’m not understanding this proxy error

please help me


#5

and me i did not understand what this proxy error is??


#6

i have same problem and not understand how you resolved. please help us


#7

after run ionic start myApp tabs I had also got same error. but directory created myApp
so i went inside directory and run command npm install and then ionic serve & its work for me.


#8

Windows:-
You can install with npm.
open cmd with Administration Acess
then, npm install --global --production windows-build-tools
after that
npm install --global node-gyp


#9

install install all node-gyp** dependencies by following command

$ npm install --global --production windows-build-tools
and then install the package

$ npm install --global node-gyp


#10

I was updated Windows yesterday night, and I got the same problem.
And I solved this problem, your comment really helped me.
Thank you Rocker619!!