ERR_CLEARTEXT_NOT_PERMITTED in debug app on Android

It worked Magically.
Thanks.

i created account only for i say thanks, this worked for me

worked for me as well. Thanks.

Just Add

<base-config cleartextTrafficPermitted="true">
    <trust-anchors>
        <certificates src="system" />
    </trust-anchors>
</base-config>

to

resources/android/xml/network_security_config.xml

Like

<network-security-config>
<base-config cleartextTrafficPermitted="true">
    <trust-anchors>
        <certificates src="system" />
    </trust-anchors>
</base-config>

<domain-config cleartextTrafficPermitted="true">
    <domain includeSubdomains="true">localhost</domain>
</domain-config> </network-security-config>
9 Likes

@NurGuz
i hope this error comes because of android version 9
Try this…it worked for me

 <access origin="*" />
    <preferance name="android-usesCleartextTraffic" value="true" />
    <allow-navigation href="*" />
2 Likes

If you see Error parsing XML: unbound prefix in your failed build report, then you’ll want to add the android namespace xmlns:android="http://schemas.android.com/apk/res/android" to the root <widget> tag inside the config.xml file, then reload/build platform.

1 Like

Got the same error and then went for zbahadir’s solution but when i open AndroidManifest.xml android:usesCleartextTraffic="true" was already there. so i just remove the code that was added to the config.xml and build the app and it was working.

Thank you so much. It works to me

Hi folks,
I am also having the same issues right now after running the apk on my app.

have this on my config.xml

        <access origin="*" />
        <edit-config file="app/src/main/AndroidManifest.xml" mode="merge" target="/manifest/application" xmlns:android="http://schemas.android.com/apk/res/android">
            <application android:usesCleartextTraffic="true" />
        </edit-config>
        <allow-navigation href="*" />
        <resource-file src="resources/android/xml/network_security_config.xml" target="app/src/main/res/xml/network_security_config.xml" />
        <allow-intent href="market:*" />

and resources/android/xml/network_security_config.xml

<?xml version="1.0" encoding="utf-8"?>
<network-security-config>
    <domain-config cleartextTrafficPermitted="true">
        <domain includeSubdomains="true">localhost</domain>
               <domain includeSubdomains="true">myserverip</domain>
    </domain-config>
</network-security-config>

Thanks! This worked to me!. Before i have an error with net::ERR_CLEARTEXT_NOT_PERMITTED, and add this to config.xml :smiling_face_with_three_hearts: (This is an error in Android 9 version)

I had the same issue for a couple of days too and this worked for me after trying many options

config.xml

<edit-config file="app/src/main/AndroidManifest.xml" 
   mode="merge" target="/manifest/application" 
   xmlns:android="http://schemas.android.com/apk/res/android">
     <application android:usesCleartextTraffic="true" />
     <application android:networkSecurityConfig="@xml/network_security_config" />
 </edit-config>
 <resource-file src="resources/android/xml/network_security_config.xml" 
 target="app/src/main/res/xml/network_security_config.xml" />

"resources/android/xml/network_security_config.xml" .

<?xml version="1.0" encoding="utf-8"?>
<network-security-config>
    <base-config cleartextTrafficPermitted="true">
        <trust-anchors>
            <certificates src="system" />
        </trust-anchors>
    </base-config>
    <domain-config cleartextTrafficPermitted="true">
        <domain includeSubdomains="true">localhost</domain>
        <domain includeSubdomains="true">YOUR DOMAIN HERE/IP</domain>
    </domain-config>
</network-security-config>

based on

This worked for me. thanks.

1 Like

Thanks, it worked for me.

Hi @sukeshk!
Welcome to the community!
Your answer helped others a lot.
Keep supporting members.
Thanks!

Not working . After add android:usesCleartextTraffic=“true” in my ionic project. And, also trying add server URL in network_security_config.xml file. But, also not working. Please help me

just to sum it up
i’ve got this working on ionic v4 tho i consider it doesnt matter

  1. you should have this option set under android prefernces in config.xml (note that without xmlns:android=**** line i am getting errors)
<access origin="*" />
<edit-config file="app/src/main/AndroidManifest.xml" mode="merge" target="/manifest/application" xmlns:android="http://schemas.android.com/apk/res/android">
       <application android:networkSecurityConfig="@xml/network_security_config" />
</edit-config>
  1. next - under “resources/android/xml/network_security_config.xml” if you have https connection with self singed certificate you should add
<network-security-config>
   <base-config cleartextTrafficPermitted="true">
       <trust-anchors>
           <certificates src="system" />
       </trust-anchors>
   </base-config>
</network-security-config>
  1. include all ur http calls to DOMAINS under this option
<network-security-config>
   <base-config cleartextTrafficPermitted="true">
      ******
   </base-config>
    <domain-config cleartextTrafficPermitted="true">
        <domain includeSubdomains="true">localhost</domain>
        <domain includeSubdomains="true">URDOMAIN_NOT_IP.com</domain>
    </domain-config> </network-security-config>
</network-security-config>
  1. consider reading official documentation as well

if it still is not working, try to take a look in AndroidManifest.xml in build, to take a look if something is wrong

worked for me :slight_smile: tks

1 Like

Just Replace this:

<application android:networkSecurityConfig="@xml/network_security_config" />

and Add this:

<application android:usesCleartextTraffic="true" />

Example config.xml:

<edit-config file="app/src/main/AndroidManifest.xml" mode="merge" target="/manifest/application" xmlns:android="http://schemas.android.com/apk/res/android">
    <application android:usesCleartextTraffic="true" />
</edit-config>

I hope to solve your problem.

1 Like

It Worked ! ,thanks buddy ,i just signup to say thanks a lot ,wish you all the best

Im using IONIC 5.4.13, cordova 9.0.0 (cordova-lib@9.0.1)

I might be repeating information but for me problem started appearing after adding some plugin (not sure yet). I tried all above combinations, but nothing worked. It only started working after adding:

   <base-config cleartextTrafficPermitted="true">
       <trust-anchors>
           <certificates src="system" />
       </trust-anchors>
   </base-config>

to file in project at

resources/android/xml/network_security_config.xml

so my network_security_config.xml file now looks like:

<?xml version="1.0" encoding="utf-8"?>
<network-security-config>
   <base-config cleartextTrafficPermitted="true">
       <trust-anchors>
           <certificates src="system" />
       </trust-anchors>
   </base-config>
    <domain-config cleartextTrafficPermitted="true">
        <domain includeSubdomains="true">localhost</domain>
        <domain includeSubdomains="true">10.1.25.10</domain>
    </domain-config>
</network-security-config>

Thanks to all.

2 Likes