Embedding a 3rd party framework

Hi,

I’m completely new to iOS/Swift and I’ve run into some difficulties while trying to embed a 3rd party framework.

Anything on cocoapods seems easy enough, I simply edit the pods/podspec files and run pod install. The problem begins when I try to directly embed a 3rd party framework.

I’ve tried following this stack overflow guide: https://stackoverflow.com/questions/58045726/how-to-embed-third-party-framework-on-ionic-capacitor-custom-plugin

I’ve dragged/linked the framework to the Pods/frameworks folder and it’s visible on the ‘Framewokrs and Libraries’ project view (with embed & sign). This isn’t enough as the main project can’t locate the framework yet.

So I’ve tried updating the podfile with something like:
pod 'frameworkName', :path => './Pods/frameworkName.framework'
under the capacitor_pods, and dragged the framework again from the pods to the Plugin/Frameworks folder. If I chose to copy the framework it works when I compile the plugin but fails when I try to import it (and besides copying it twice makes little sense). On the other hand, simply linking it does nothing (can’t compile the plugin).

I’ve also edited the podspec file
s.vendored_frameworks = 'ios/Pods/frameworkFolder/**'

I’m sure I’m missing something rather basic, I just couldn’t find any documentation to guide me at the right direction